二分查找的简单应用

问题

1085 Perfect Sequence (25 分)
Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:
Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10
5
) is the number of integers in the sequence, and p (≤10
9
) is the parameter. In the second line there are N positive integers, each is no greater than 10
9
.

Output Specification:
For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
结尾无空行
Sample Output:
8

思路

对数组从小到大遍历,然后枚举每一个元素,使之与p相乘,利用upper_bound找到第一个大于该乘积的元素。更新元素个数的最大值。

代码

#include <bits/stdc++.h>
using namespace std;
const int maxn = 100010;
int seq[maxn];
int main(){
    int n,p,temp,ans=1;
    cin>>n>>p;
    for (int i = 0; i < n; ++i) {
        cin>>temp;
        seq[i] = temp;
    }
    sort(seq,seq+n);
    for (int j = 0; j < n; ++j) {
        int x = upper_bound(seq+j+1,seq+n,(long long)seq[j]*p)-seq;
        ans = max(ans,x-j);
    }
    cout<<ans;
    return 0;
}

总结

记住upper_bound()函数和lower_bound()函数的用法,可以简化大量的代码。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值