数独



#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
/* 构造完成标志 */
int sign;   //0代表false,1代表true
/* 创建数独矩阵 */
int num[9][9];
/* 函数声明 */
void Input();
void Output();
int Check(int n, int key);//返回0代表false,1代表true
int DFS(int n);

/* 主函数 */
int main()
{
    int test,i,j;
    scanf("%d",&test);
    while(test--)
    {
		sign=0;//设初始值为0
	    Input();//输入
	    DFS(0);
	    Output();//输出
    }
}

/* 读入数独矩阵 */
void Input()
{
    int i,j;
    for (i = 0; i < 9; i++)
        for (j = 0; j < 9; j++)
        	scanf("%1d",&num[i][j]);//一个数一个数的读
}

/* 输出数独矩阵 */
void Output()
{
    int i,j;
    for (i = 0; i < 9; i++)
    {
        for (j = 0; j < 9; j++)
        {
            printf("%d",num[i][j]);
        }
        printf("\n");
    }
}

/* 判断key填入n时是否满足条件 */
int Check(int n, int key)
{
    /* 判断n所在横列是否合法 */
    int i,j;
    int x,y;
    for (j = 0; j < 9; j++)
    {
        /* i为n竖坐标 */
        i = n / 9;
		//如果有相同的数,返回0(不合法)
        if (num[i][j] == key) return 0;
    }

    /* 判断n所在竖列是否合法 */
    for (i = 0; i < 9; i++)
    {
        /* j为n横坐标 */
        j = n % 9;
		//如果有相同的数,返回0(不合法)
        if (num[i][j] == key) return 0;
    }

    /* x为n所在的小九宫格左顶点竖坐标 */
    x = n / 9 / 3 * 3;//如:38/9/3*3=3

    /* y为n所在的小九宫格左顶点横坐标 */
    y = n % 9 / 3 * 3;//如:38%9/3*3=6

    /* 判断n所在的小九宫格是否合法 */
    for (i = x; i < x + 3; i++)
    {
        for (j = y; j < y + 3; j++)
        {
            if (num[i][j] == key) return 0;
        }
    }

    /* 全部合法,返回正确 */
    return 1;
}

/* 深搜构造数独 */
int DFS(int n)
{
    /* 所有的都符合,退出递归 */
    int i;
    if (n > 80)
    {
        sign = 1;
        return 0;
    }
    /* 当前位不为空时跳过 */
    if (num[n/9][n%9] != 0)
    {
        DFS(n+1);
    }
    else
    {
        /* 否则对当前位进行枚举测试 */
        for (i = 1; i <= 9; i++)
        {
            /* 满足条件时填入数字 */
            if (Check(n, i) == 1)
            {
                num[n/9][n%9] = i;
                /* 继续搜索 */
                DFS(n+1);
                /* 返回时如果构造成功,则直接退出 */
                if (sign == 1) return 0;
                /* 如果构造不成功,还原当前位 */
                num[n/9][n%9] = 0;
            }
        }
    }
}

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task.

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127
 
     
以下代码用时更短。。。。。
 
     
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int map[10][10],count1;
bool row[10][10],coloumn[10][10],cr[10][10];//用来标记行,竖,小方格
struct p
{
	int x,y;
}point[100];//标记每个格子的横纵坐标
int cxbfine(int i,int j)//规定每个3*3方格的号码
{
	return ((i-1)/3)*3+(j-1)/3;
}
int dfs(int n)//进行深搜,符合条件往下,填不下就回溯
{
	if(n>count1)
		return 1;
	for(int i=1;i<=9;i++)
		if(!row[point[n].x][i] && !coloumn[point[n].y][i] && !cr[cxbfine(point[n].x,point[n].y)][i])
		{
			row[point[n].x][i]=true;
			coloumn[point[n].y][i]=true;
			cr[cxbfine(point[n].x,point[n].y)][i]=true;
			map[point[n].x][point[n].y]=i;
			if(dfs(n+1))
				return 1;
			row[point[n].x][i]=false;
			coloumn[point[n].y][i]=false;
			cr[cxbfine(point[n].x,point[n].y)][i]=false;
		}
		return 0;
}
int main()
{
	int n,i,j;
	cin>>n;
	while(n--)
	{
		count1=0;
		memset(row,false,sizeof(row));
		memset(coloumn,false,sizeof(coloumn));
		memset(cr,false,sizeof(cr));
		for(i=1;i<=9;i++)//输入并判断
			for(j=1;j<=9;j++)
			{
				scanf("%1d",&map[i][j]);
				if(map[i][j])
				{
					row[i][map[i][j]]=true;
					coloumn[j][map[i][j]]=true;
					cr[cxbfine(i,j)][map[i][j]]=true;
				}
				else
				{
					count1++;
					point[count1].x=i;
					point[count1].y=j;
				}
			}
		dfs(1);
		for(i=1;i<=9;i++)
		{
			for(j=1;j<=9;j++)
				cout<<map[i][j];
			cout<<endl;
		}
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
一个简单的解数独的小程序 //***求数独的解,参数mod为0或1,time0为搜索开始时的时间,mod=0时仅检查Data1中数独是否有解,有解则抛出1,mod=1时求出所有解并输出*** { int i,j,im=-1,jm,min=10; int mark[10]; for(i=0;i<9;i++) { for(j=0;j<9;j++) { if(Data1[i][j]) //如果该位置有数据则跳过 { continue; } int c=Uncertainty(i,j,mark); //如果该位置为空则先求不确定度 if(c==0) //如果不确定度为0则表示该数独无解 { return; } if(c<min) //得到不确定度最小的位置(第im行 第jm列 不确定度为min) { im=i; jm=j; min=c; } } } if(im==-1) //所有位置都已经确定,数独已经解出,按要求输出解 { if(mod==1) //显示所有解 { if(IsSolved()==true) { if(Solutions++<MAXANSNUM) { cout<<"第 "<<Solutions<<" 个 解:"<<endl; Display(1); } if((time(NULL)-time0)>TIMEOUT) { throw(Solutions); } } return; } else //只给出一个解 { throw(1); //跳出所有递归调用,返回1 } } Uncertainty(im,jm,mark); //从不确定度最小的位置开始解 for(i=1;i<=9;i++) { if(mark[i]==0) { Data1[im][jm]=i; //对不确定度最小的位置尝试可能的赋值 Search(mod,time0); //递归调用 } } Data1[im][jm]=0; } void Csudoku::Set(int n) //***随机生成数独,参数n表示数独中待填元素个数*** { srand((unsigned)time(NULL)); int i,j,k; do { for(i=0;i<9;i++) //随机给每行的某一个位置赋值 { for(j=0;j<9;j++) { Data1[i][j]=0; } j=rand()%9; Data1[i][j]=i+1; } } while(!Solve(0)); //按照随机赋的值给出一个解 for(k=0;k<n;) //从中随机去掉n个数据 { i=rand()%81; j=i%9; i=i/9; if(Data1[i][j]>0) { Data1[i][j]=0; k++; } } for(i=0;i<9;i++) //将生成的数独存入Data0数组 { for(j=0;j<9;j++) { Data0[i][j]=Data1[i][j]; } } }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值