Brackets Sequence



Description

Let us define a regular brackets sequence in the following way:

1. Empty sequence is a regular sequence.
2. If S is a regular sequence, then (S) and [S] are both regular sequences.
3. If A and B are regular sequences, then AB is a regular sequence.

For example, all of the following sequences of characters are regular brackets sequences:

(), [], (()), ([]), ()[], ()[()]

And all of the following character sequences are not:

(, [, ), )(, ([)], ([(]

Some sequence of characters '(', ')', '[', and ']' is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1 a2 ... an is called a subsequence of the string b1 b2 ... bm, if there exist such indices 1 = i1 < i2 < ... < in = m, that aj = bij for all 1 = j = n.

Input

The input file contains at most 100 brackets (characters '(', ')', '[' and ']') that are situated on a single line without any other characters among them.

Output

Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input

([(]

Sample Output

()[()]
 
  
 
  

题目描述:

定义合法的括号序列如下:

1 空序列是一个合法的序列

2 如果S是合法的序列,则(S)和[S]也是合法的序列

3 如果A和B是合法的序列,则AB也是合法的序列

例如:下面的都是合法的括号序列

(),  [],  (()),  ([]),  ()[],  ()[()]

下面的都是非法的括号序列

(,  [,  ),  )(,  ([)],  ([(] 

给定一个由'(',  ')',  '[', 和 ']' 组成的序列,找出以该序列为子序列的最短合法序列。

解题思路:

根据“黑书”的思路,定义:

d[i][j]为输入序列从下标i到下标j最少需要加多少括号才能成为合法序列。0<=i<=j<len (len为输入序列的长度)。

c[i][j]为输入序列从下标i到下标j的断开位置,如果没有断开则为-1。

i==j时,d[i][j]为1

当s[i]=='(' && s[j]==')' 或者 s[i]=='[' && s[j]==']'时,d[i][j]=d[i+1][j-1]

否则d[i][j]=min{d[i][k]+d[k+1][j]} i<=k<j ,  c[i][j]记录断开的位置k

采用递推方式计算d[i][j]

输出结果时采用递归方式输出print(0, len-1)

输出函数定义为print(int i, int j),表示输出从下标i到下标j的合法序列

当i>j时,直接返回,不需要输出

当i==j时,d[i][j]为1,至少要加一个括号,如果s[i]为'(' 或者')',输出"()",否则输出"[]"

当i>j时,如果c[i][j]>=0,说明从i到j断开了,则递归调用print(i, c[i][j]);和print(c[i][j]+1, j);

                如果c[i][j]<0,说明没有断开,如果s[i]=='(' 则输出'('、 print(i+1, j-1); 和")"

                                                                     否则输出"[" print(i+1, j-1);和"]"

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
typedef long long LL;
const int MAX=0x3f3f3f3f;
int n,dp[105][105],c[105][105];
char s[105];
void print(int i,int j)
{
    if( i > j ) return ;
    if( i == j )
    {
        if( s[i] == '(' || s[i] == ')' ) printf("()");
        else printf("[]");
        return;
    }
    if( c[i][j] >= 0 )
    {
        print( i,c[i][j] );
        print( c[i][j]+1,j );
    }
    else
    {
        if( s[i] == '(' )
        {
            printf("(");
            print(i+1,j-1);
            printf(")");
        }
        else
        {
            printf("[");
            print(i+1,j-1);
            printf("]");
        }
    }
}
int main()
{
    scanf("%s",s+1);
    n = strlen(s+1);
    memset(dp,MAX,sizeof(dp));
    memset(c,-1,sizeof(c));
    for(int i=1; i<=n; i++)
        dp[i][i] = 1, dp[i][i-1] = 0;
    for(int len = 1; len <= n; len++)
        for(int i = 1; i <= n-len; i++)
        {
            int j = i+len;
            for(int k = i; k < j; k++)
                if( dp[i][j] > dp[i][k]+dp[k+1][j] )
                {
                    dp[i][j] = dp[i][k]+dp[k+1][j];
                    c[i][j] = k;
                }
            if( (s[i] == '(' && s[j] == ')' || s[i] == '[' && s[j] == ']') && dp[i][j] > dp[i+1][j-1] )
            {
                dp[i][j] = dp[i+1][j-1];
                c[i][j] = -1;
            }
        }
    for(int i=1; i<=n; i++)
    {
        for(int j=1; j<=n; j++)
            printf("%d ",c[i][j]);
        printf("\n");
    }
    print( 1,n );
    printf("\n");
    return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值