Bribing FIPA(树形DP)



Description

There is going to be a voting at FIPA (Fédération Internationale de Programmation Association) to determine the host of the next IPWC (International Programming World Cup). Benjamin Bennett, the delegation of Diamondland to FIPA, is trying to seek other delegation's support for a vote in favor of hosting IWPC in Diamondland. Ben is trying to buy the votes by diamond gifts. He has figured out the voting price of each and every country. However, he knows that there is no need to diamond-bribe every country, since there are small poor countries that take vote orders from their respected superpowers. So, if you bribe a country, you have gained the vote of any other country under its domination (both directly and via other countries domination). For example, if C is under domination of B, and B is under domination of A, one may get the vote of all three countries just by bribing A. Note that no country is under domination of more than one country, and the domination relationship makes no cycle. You are to help him, against a big diamond, by writing a program to find out the minimum number of diamonds needed such that at least m countries vote in favor of Diamondland. Since Diamondland is a candidate, it stands out of the voting process.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers n (1 ≤ n ≤ 200) and m (0 ≤ mn) which are the number of countries participating in the voting process, and the number of votes Diamondland needs. The next n lines, each describing one country, are of the following form:

CountryNameDiamondCountDCName1DCName1 ...

CountryName, the name of the country, is a string of at least one and at most 100 letters and DiamondCount is a positive integer which is the number of diamonds needed to get the vote of that country and all of the countries that their names come in the list DCName1DCName1 ... which means they are under direct domination of that country. Note that it is possible that some countries do not have any other country under domination. The end of the input is marked by a single line containing a single # character.

Output

For each test case, write a single line containing a number showing the minimum number of diamonds needed to gain the vote of at least m countries.

Sample Input

3 2
Aland 10
Boland 20 Aland
Coland 15
#

Sample Output

20

题意:给定N个国家,相互之间可能存在附属关系,现在想要贿赂m个国家,已知,贿赂一个国家,那么如果该国家拥有附属国,那么他的所有附属国都可以算作已经贿赂。

分析:按照国家之间的附属关系连边(有向),之后将森林转为一棵树,就变成了一棵树上的01背包了。

因为国家是用名字给出的,先用字典树给名字编号,dp[i][j]表示第i个国家及其附属国中选j个国家的最小花费。


#include<iostream>
#include<algorithm>
#include<string.h>
#include<string>
#include<vector>
using namespace std;
const int N = 210;
int n,num,m,dp[N][N],w[N],in[N];
char s[20110];
bool vis[N];
vector<int> g[N];
typedef struct node    
{    
    int cnt;    
    struct node *next[52];   
}*tree,Trie;    
tree root;  
inline int GetNum(char *t){  
    tree p = root,newnode;  
    for(int i = 0;i < strlen(t); ++i){  
        int u = t[i] - 'a';  
        if(u<0) u=t[i]-'A'+26;
        if(p->next[u]==NULL)  
        {     
            newnode=(tree)malloc(sizeof(Trie));  
            newnode->cnt=-1;  
            for(int j=0;j<52;j++)  
                newnode->next[j]=NULL;  
            p->next[u]=newnode;  
            p=newnode;  
        }  
        else 
        p = p->next[u];  
    }  
    if(p->cnt == -1) //该节点未出现过  
        p->cnt = num ++;  
    return p->cnt;  
}  
void init()
{
    root=(tree)malloc(sizeof(Trie));  
    root->cnt=-1; 
    for(int j=0;j<52;j++)  
        root->next[j]=NULL; 
    num=1;
    memset(in,0,sizeof(in));
    for(int i=0;i<=n;i++)
        g[i].clear();
    for(int i=0;i<=n;i++)
        for(int j=0;j<=n;j++)
            dp[i][j]=INT_MAX;
}
int dfs(int u)
{
    int size=g[u].size();
    dp[u][0]=0;
    int t=0;
    for(int i=0;i<size;i++)
    {
        int v=g[u][i];
        int now=dfs(v);
        for(int j=t;j>=0;j--)//当前z树选择j个点
        {
            for(int k=0;k<=now;k++)//以v为根的子树选择k个点
                dp[u][j+k]=min(dp[u][j+k],dp[u][j]+dp[v][k]);
        }
        t+=now;
    }
    for(int i=1;i<=t+1;i++)//注意,这里就是题目的关键了,如果选择了父节点,那么父节点可以当成子树的所有状态值
        dp[u][i]=min(dp[u][i],w[u]);
    return t+1;
}
int main()
{
    char str[100],c[110];
    while(scanf("%s",str)==1)
    {
        if(strcmp(str,"#")==0)
            break;
        n=atoi(str);
        scanf("%d",&m);
        getchar();
        init();
        for(int i=0;i<n;i++)
        {
            gets(s);
            int len=strlen(s),cc=0,t=0,a,b;
            for(int j=0;j<=len;j++)
            {
                if(s[j]!=' ' && s[j]!='\0')
                  c[t++]=s[j];
                if(s[j]==' '||s[j]=='\0')
                {
                    cc++;
                    c[t]='\0';
                    t=0;
                    if(cc==1)
                        a=GetNum(c);
                    else if(cc==2)
                        w[a]=atoi(c);
                    else {
                        b=GetNum(c);
                        g[a].push_back(b);
                        in[b]++;
                    }
                }
            }
        }
        for(int i=1;i<=n;i++)//将森林转为树
        {
            if(in[i]==0)
                g[0].push_back(i);
        }
        w[0]=INT_MAX;//0节点是自己添加的,它对应的花费应该设定为正无穷,这样就不会选择这个点了
        dfs(0);
        printf("%d\n",dp[0][m]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值