hdu1003 Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 209425    Accepted Submission(s): 49082


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6




代码:

#include <iostream>

#include<string.h>
using namespace std;
int a[100005];
int main()
{
    int t;
    cin>>t;
    for(int i=1;i<=t;i++)
    {
        int n;
        cin>>n;
        int s=1,ns=1,e=1,sum=-10002,max=-10002;    //s:start,e:end,ns:此时判断的起点 
       // memset(a,0,sizeof(a));
        for(int j=1;j<=n;j++)
        {
            cin>>a[j];
            if(sum+a[j]<a[j])
            {
                sum=a[j];
                ns=j;
            }
            else
                sum+=a[j];


        if(sum>max)
        {
            max=sum;
            s=ns;
            e=j;
        }
        }


        cout<<"Case "<<i<<":"<<endl;
        cout<<max<<" "<<s<<" "<<e<<endl;
        if(i!=t)
            cout<<endl;
    }


    return 0;

}

题意:求出和最大的序列

对于每个数有两种处理方式:

1.加到前面的序列中,变为前面最大和中的一个量

2.自己独立形成一个最大序列和

若前一个子段i-1的最大和<0,则最大子段的计数从i开始算,即选择第二种处理方式。



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值