POJ 2488 DFS

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
//挖掘机_Coder_zha学习之路
#include<iostream> 
#include<cstdio> 
#include<cstring> 
using namespace std; 
int m,n,jug,step[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}}; 
bool mp[30][30]; 
char line[27][2]; 
void DFSCCCCCCCCCCCCC(int x,int y,int t) 
{ 
    if(t==m*n) {jug=1;line[t][0]=y+64;line[t][1]=x;return;} 
    if(x<1||x>m||y<1||y>n) return; 
    int xx,yy; 
    for(int i=0;i<8;i++) 
    { 
        xx=x+step[i][0],yy=y+step[i][1]; 
        if(xx<1||xx>m||yy<1||yy>n||mp[xx][yy]) continue; 
        mp[xx][yy]=1; 
        DFSCCCCCCCCCCCCC(xx,yy,t+1); 
        if(jug) {line[t][0]=y+64;line[t][1]=x;return;} 
        mp[xx][yy]=0; 
    } 
} 
int main() 
{ 
    int i,j,T,t; 
    cin>>T;
    for(t=1;t<=T;t++) 
    { 
        cin>>m>>n; 
        jug=0;memset(mp,0,sizeof(mp)); 
        printf("Scenario #%d:\n",t); 
        mp[1][1]=1; 
        DFSCCCCCCCCCCCCC(1,1,1); 
        if(jug) 
        { 
            for(i=1;i<=m*n;i++) 
                printf("%c%d",line[i][0],line[i][1]); 
            printf("\n"); 
        } 
        else    printf("impossible\n"); 
         
        if(t!=T)    printf("\n"); 
    } 
    return 0; 
} 
自己的思路是走一步,记录一步,错误就返回删除,这样回溯太多,借鉴别人的,走到成功了在回溯标记(SB我是)
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值