UVA674 完全背包DP

UVA674

完全背包的DP题,有50,25,10,5和1块的硬币,问拼出N元有多少种方案, 状态转移方程 dp[i][j]+=dp[i-1][j-c[i]] 其中dp[i][j]表示前i个硬币可凑成j元的方案数,因为硬币可以重复拿,所以是类似完全背包的DP题,优化一下空间参见代码,搜了一下题解好多人用的记忆化搜索..然而我并不懂…以后再看看这道题

Description

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

Input

The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input

11
26

Sample Output

4
13

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

int dp[8000];
int coin[] = {1,5,10,25,50};

int main()
{
    dp[0] = 1;
    for (int i =0;i<5;i++)
        for(int j = coin[i];j<=8000;j++)
        {
             dp[j] +=dp[j-coin[i]];
        }
    int n;
    while (scanf("%d",&n)!=EOF)
       printf("%d\n",dp[n]);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值