POJ1787

POJ1787

一开始还没看多重背包…以为是完全背包加个限制条件,然后想了好久没想不出,看了下背包九讲..看到多重背包可是也没什么思路…后来搜了一下题解…豁然开朗 dp[j] 表示 j 块钱最多由多少块硬币组成, path[j] 表示 上一次最多有多少块构成的 j 块钱, used[j] 表示 j 块钱时,已经放了多少同种类的硬币。

Description

Charlie is a driver of Advanced Cargo Movement, Ltd. Charlie drives a lot and so he often buys coffee at coffee vending machines at motorests. Charlie hates change. That is basically the setup of your next task.

Your program will be given numbers and types of coins Charlie has and the coffee price. The coffee vending machines accept coins of values 1, 5, 10, and 25 cents. The program should output which coins Charlie has to use paying the coffee so that he uses as many coins as possible. Because Charlie really does not want any change back he wants to pay the price exactly.

Input

Each line of the input contains five integer numbers separated by a single space describing one situation to solve. The first integer on the line P, 1 <= P <= 10 000, is the coffee price in cents. Next four integers, C1, C2, C3, C4, 0 <= Ci <= 10 000, are the numbers of cents, nickels (5 cents), dimes (10 cents), and quarters (25 cents) in Charlie’s valet. The last line of the input contains five zeros and no output should be generated for it.

Output

For each situation, your program should output one line containing the string “Throw in T1 cents, T2 nickels, T3 dimes, and T4 quarters.”, where T1, T2, T3, T4 are the numbers of coins of appropriate values Charlie should use to pay the coffee while using as many coins as possible. In the case Charlie does not possess enough change to pay the price of the coffee exactly, your program should output “Charlie cannot buy coffee.”.

Sample Input

12 5 3 1 2
16 0 0 0 1
0 0 0 0 0

Sample Output

Throw in 2 cents, 2 nickels, 0 dimes, and 0 quarters.
Charlie cannot buy coffee.

代码


#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
const int inf = -1;
const int maxn = 10010;

int dp[maxn],path[maxn],used[maxn];

int main()
{
    int num[4],val[4] = {1,5,10,25};
    int n;
    while (scanf("%d%d%d%d%d",&n,&num[0],&num[1],&num[2],&num[3]))
    {
        if(n==0&&num[0]==0&&num[1]==0&&num[2]==0&&num[3]==0)break;
        memset(dp,inf,sizeof(dp));
        memset(path,0,sizeof(path));
        path[0] = -1;
        dp[0] = 0;

        int i,j;
        for (i = 0;i<4;i++)
        {
                memset(used,0,sizeof(used));
                for (j = val[i];j<=n;j++)
                {
                        if (dp[j-val[i]]+1>dp[j] && dp[j-val[i]] >=0 && used[j-val[i]]<num[i])
                        {
                                dp[j] = dp[j-val[i]]+1;
                                used[j] = used[j-val[i]]+1;
                                path[j] = j - val[i];
                        }
                }
        }

        int ans[100];
        memset(ans,0,sizeof(ans));
        if (dp[n] < 0)
        {
             printf("Charlie cannot buy coffee.\n");
        }
        else
        {
                while (path[n] != -1)
                {
                        ans[n-path[n]]++;
                        n = path[n];
                }
        printf("Throw in %d cents, %d nickels, %d dimes, and %d quarters.\n", ans[val[0]], ans[val[1]], ans[val[2]], ans[val[3]]);
        }
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值