/*
* Copyright (c) 2014, 烟台大学计算机学院
* All rights reserved.
* 文件名称:test.cpp
* 作 者:李晓凯
* 完成日期:2015年 6 月 20 日
* 版 本 号:v1.0
*
* 问题描述:
* 输入描述:
* 程序输出:
*/
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
解析:动规题:
先从第一位开始往后加;把最大值用max记录;
如果sum<0那说明 前面的白加,因为前面加起来是负数 你后面怎么加都会比加上负数的大
如果你把前面加起来是负数的区间也加上,那后面的最大值会变小;
6 -1 5 4 -7
6 +(-1)+5+4=14 max=14;
代码;
#include <iostream>
using namespace std;
int main()
{
int t,n,temp,pos1,pos2,max,now,x,i,j;
cin>>t;
for (i=1;i<=t;i++)
{
cin>>n>>temp;
now=max=temp;
pos1=pos2=x=1;
for (j=2;j<=n;j++)
{
cin>>temp;
if (now+temp<temp)
now=temp,x=j;
else
now+=temp;
if (now>max)
max=now,pos1=x,pos2=j;
}
cout<<"Case "<<i<<":"<<endl<<max<<" "<<pos1<<" "<<pos2<<endl;
if (i!=t)
cout<<endl;
}
return 0;
}