c++大正整数的加法

A + B Problem

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include<iostream>
#include<string>
using namespace std;
int main()
{
	string a, b;
	int c[2000];
	int q = 1;
	int p;
	cin >> p;
	for (int j = 0; j < p;j++) {
		cin >> a >> b;
		cout << "Case " << q << ":" << endl;
		cout << a << " + " << b << " = ";
		reverse(a.begin(), a.end());
		reverse(b.begin(), b.end());
		string d = a.length() > b.length() ? a : b;
		string e = a.length() > b.length() ? b : a;
		int f = 0;
		int flag = 0;
		for (int i = 0; i < e.length(); i++) {
			if (a[i] + b[i] + f - 96 > 9) {
				c[i] = f + a[i] + b[i] - 96 - 10;
				f = 1;
			}
			else {
				c[i] = f + a[i] + b[i] - 96;
				f = 0;
			}
			flag++;
		}
		for (int i = e.length(); i < d.length(); i++) {
			if (d[i] -48 + f > 9) {
				c[i] = f + d[i] - 48 - 10;
				f = 1;
			}
			else {
				c[i] = f + d[i] - 48;
				f = 0;
			}
			flag++;
		}
		if (f != 0) {
			c[d.length()] = 1;
			flag++;
		}
		for (int i = flag-1; i >= 0; i--) {
			cout << c[i];
		}
		if(j<p-1){
			cout << endl;
			cout << endl;
		}
		else cout << endl;
		q++;
	}
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值