poj 1328 Radar Installation【贪心】

Radar Installation

 

转载地址:http://blog.chinaunix.net/uid-22609852-id-3506134.html

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 53   Accepted Submission(s) : 27
Problem Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


 

Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
 

Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
 

Sample Input
  
  
3 2 1 2 -3 1 2 1 1 2 0 2 0 0
 

Sample Output
  
  
Case 1: 2 Case 2: 1
 

Source
分析:
这道题有些不懂,现在标记一下,往后来看。
代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<iostream>
using namespace std;

#define MAX 1010

struct node {
	double xl;
	double xr;
}is[MAX];

int cmp(const void *a,const void *b)
{
	return ((node *)a)->xl>((node *)b)->xl?1:-1; 
}

int gre(node is[],int n,int d)
{
	int num=0,i;
	double cur;
	cur=is[0].xr;
	num++;
	for(i=1;i<n;i++)
	{
		if(is[i].xl-cur>1e-5)
		{
			num++;
			cur = is[i].xr;
		}
		else {
			if(is[i].xr-cur<1e-5)
			{
				cur=is[i].xr;
			}
		}
	}
	return num;
}

int main()
{
	int i,n,d,x,y,cout=0,flag=0;
	 node is[MAX]={0};
	double of;
	while(scanf("%d%d",&n,&d)==2&&!(n==d&&d==0))
	{
		flag=0;
		cout++;
		for(i=0;i<n;i++)
		{
			scanf("%d %d",&x,&y);
			if(y>d)
			{
				flag=1;
			}
			of=sqrt((double)(d*d-y*y));
			is[i].xl=x-of;
			is[i].xr=x+of;
		}
		if(flag)
		{
			printf("Case %d: -1n",cout);
			continue;
		}
		qsort(is,n,sizeof(is[0]),cmp);
		i=gre(is,n,d);
		printf("Case %d: %d",cout,i);
	} 
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值