hdoj 1241 【DFS】

Oil Deposits

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
  
  
0 1 2 2 分析:简单的深搜,计算连着的油桶的数量。
代码:
  
Online Judge Online Exercise Online Teaching Online Contests Exercise Author 
F.A.Q
Hand In Hand
Online Acmers 
Forum | Discuss
Statistical Charts
 Problem Archive
Realtime Judge Status
Authors Ranklist
        C/C++/Java Exams     
ACM Steps
Go to Job
Contest LiveCast
ICPC@China
 Best Coder beta
VIP | STD Contests
Virtual Contests 
    DIY | Web-DIY beta
Recent Contests
  小破孩儿
 Mail 0(0)
 Control Panel 
 Sign Out 
 

欢迎参加——每周六晚的BestCoder(有米!)
 
View Code
Problem : 1241 ( Oil Deposits )     Judge Status : Accepted
RunId : 14334415    Language : G++    Author : xiaopohaier
Code Render Status : Rendered By HDOJ G++ Code Render Version 0.01 Beta
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stdlib.h>
using namespace std;
char map[102][102];
int dir[8][2]={1,0,-1,0,0,1,0,-1,1,1,-1,1,1,-1,-1,-1};
int n,m;

void dfs(int x,int y)
{
    for(int i=0;i<8;i++)
    {
        int dx=x+dir[i][0];
        int dy=y+dir[i][1];
        if(dx>=0&&dy>=0&&dx<n&&dy<m&&map[dx][dy]=='@')
        {
            map[dx][dy]='*';
            dfs(dx,dy);
        }
    }
}

int main()
{
    int i,j;
    int sum;
    while(scanf("%d%d",&n,&m)!=EOF,n&&m)
    {
        sum=0;
        for(i=0;i<n;i++)
        scanf("%s",map[i]);
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
               if(map[i][j]=='@')
               {
                   dfs(i,j);
                   sum++;
               }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stdlib.h>
using namespace std;
char map[102][102];
int dir[8][2]={1,0,-1,0,0,1,0,-1,1,1,-1,1,1,-1,-1,-1};
int n,m;

void dfs(int x,int y)
{
    for(int i=0;i<8;i++)
    {
        int dx=x+dir[i][0];
        int dy=y+dir[i][1];
        if(dx>=0&&dy>=0&&dx<n&&dy<m&&map[dx][dy]=='@')
        {
            map[dx][dy]='*';
            dfs(dx,dy);
        }
    }
}

int main()
{
    int i,j;
    int sum;
    while(scanf("%d%d",&n,&m)!=EOF,n&&m)
    {
        sum=0;
        for(i=0;i<n;i++)
        scanf("%s",map[i]);
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
               if(map[i][j]=='@')
               {
                   dfs(i,j);
                   sum++;
               }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值