Hdoj 1241 油井、DFS入门题:【题解】

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
GeoSurvComp地质调查公司负责探测地下石油储藏。 GeoSurvComp现在在一块矩形区域探测石油,并把这个大区域分成了很多小块。他们通过专业设备,来分析每个小块中是否蕴藏石油。如果这些蕴藏石油的小方格相邻,那么他们被认为是同一油藏的一部分。在这块矩形区域,可能有很多油藏。你的任务是确定有多少不同的油藏。

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ’ * ‘, representing the absence of oil, or ` @ ‘, representing an oil pocket.
输入可能有多个矩形区域(即可能有多组测试)。每个矩形区域的起始行包含m和n,表示行和列的数量,1<=n,m<=100,如果m =0表示输入的结束,接下来是n行,每行m个字符。每个字符对应一个小方格,并且要么是’*’,代表没有油,要么是’@’,表示有油。

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
对于每一个矩形区域,输出油藏的数量。两个小方格是相邻的,当且仅当他们水平或者垂直或者对角线相邻(即8个方向)。

Sample Input

1 1
*
3 5
@@*
@
@@*
1 8
@@***@
5 5
****@
@@@
@**@
@@@
@
@@**@
0 0

Sample Output

0
1
2
2

思路:

本题要求有几片互相可达的区域有油田,油田用@表示。可走的有八个方向:上下左右,左上左下,右上右下。在多组输入下,输出每次不同的连通区域。很明显时搜索题,这道题应该DFS和BFS可以用,我就用DFS做一下学习吧,我做的第一个DFS题目。

AC代码如下:

#include <iostream>
#include <cstdio>

using namespace std;
const int maxn = 105;				// maxn不能开太大	 
char mapp[maxn][maxn];
int n, m;
int dx[] = {0, 0, 1, 1, 1, -1, -1, -1};
int dy[] = {1, -1, 1, -1, 0, 1, -1, 0};

bool check(int x, int y){ //判断是否满足题意的范围
	if(x >= 0 && x < n && y >= 0 && y < m && mapp[x][y] == '@')
		return 1;
	return 0;
	
}
void dfs(int x, int y){
	if(!check(x, y))				// 一直遍历到不满足check为止 
		return;
	mapp[x][y] = '*';				// 只要进行一次遍历,就赋值为*
	for(int i = 0; i < 8; i++)
		dfs(x + dx[i], y + dy[i]); 		// 不断dfs,将能连通的地方全部赋为* 
}

int main(){
	while(scanf("%d %d", &n, &m) != EOF){	
		if(n == 0 && m == 0)	break;
		for(int i = 0; i < n; i++)
			scanf("%s", mapp[i]);
		int res = 0;
		for(int i = 0; i < n; i++)
			for(int j = 0; j < m; j++){
				if(mapp[i][j] == '@'){			// 对有@的部分进行遍历	 
					res++;						// 只要存在@那么块数就要++ 
					dfs(i, j);
				}
			} 
		printf("%d\n", res);
	}
	return 0;
}

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值