hdoj 2404 Permutation Recovery【基础题】

Permutation Recovery

Time Limit: 10000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 470    Accepted Submission(s): 328


Problem Description
Professor Permula gave a number of permutations of the n integers 1, 2, ..., n to her students. For each integer i (1 <= i <= n), she asks the students to write down the number of integers greater than i that appears before i in the given permutation. This number is denoted ai. For example, if n = 8 and the permutation is 2,7,3,5,4,1,8,6, then a1 = 5 because there are 5 numbers (2, 7, 3, 5, 4) greater than 1 appearing before it. Similarly, a4 = 2 because there are 2 numbers (7, 5) greater than 4 appearing before it.

John, one of the students in the class, is studying for the final exams now. He found out that he has lost the assignment questions. He only has the answers (the ai's) but not the original permutation. Can you help him determine the original permutation, so he can review how to obtain the answers?
 

Input
The input consists of a number of test cases. Each test case starts with a line containing the integer n (n <= 500). The next n lines give the values of a1, ..., an. The input ends with n = 0.
 

Output
For each test case, print a line specifying the original permutation. Adjacent elements of a permutation should be separated by a comma. Note that some cases may require you to print lines containing more than 80 characters.
 

Sample Input
  
  
8 5 0 1 2 1 2 0 0 10 9 8 7 6 5 4 3 2 1 0 0
 

Sample Output
  
  
2,7,3,5,4,1,8,6 10,9,8,7,6,5,4,3,2,1
 分析:
2,7,3,5,4,1,8,610,9,8,7,6,5,4,3,2,1
已知某一排列序列的逆序列,如何恢复原来的排列序列,先考虑当全部数组都为空时,如果1的逆序数为m,那么1显然会在m+1位置上,顺序处理1,2.......k,(递增序),假设此时k的逆序数为m',那么k会出现在什么位置呢?显然1,2,,,,k-1都无法对k的逆序数产生影响,则1,2,,,,k-1占据的位置可以直接忽视,只统计那些可以对逆序数产生影响的位置(即当前依然为空的位置),从左往右遍历数组,如果遇到已被(1,2,,,,k-1)占据的数据时,直接跳过,如果遇到空位置,则统计空位置数量,直至扫描至某一位index,空数据位置数量刚好达到m',则k的位置就是index+1
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
using namespace std;
int a[510];
int b[510];
int c[510];
int T;

void permulation()
{
	int i,j;
 	for(i=1;i<=T;i++)
	{
    		for(j=1;j<=T;j++)
		{
  			if(b[j]==0)
			{
  				if(a[i]!=0)
 				--a[i];
				else
  				break;
			}
		}
 		b[j]=i;
	}
}

int main()
{
	int n;
	while(scanf("%d",&T)!=EOF,T)
	{
		memset(b,0,sizeof(b));
		for(int i=1;i<=T;i++)
		scanf("%d",&a[i]);
		permulation();
		printf("%d",b[1]);
		for(int i=2;i<=T;i++)
		printf(",%d",b[i]);
		printf("\n"); 
	}
	return 0;
} 

f
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值