hdoj 1040 As Easy As A+B 【归并排序】

As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47223    Accepted Submission(s): 20220


Problem Description
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!
 

Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
It is guarantied that all integers are in the range of 32-int.
 

Output
For each case, print the sorting result, and one line one case.
 

Sample Input
  
  
2 3 2 1 3 9 1 4 7 2 5 8 3 6 9
 

Sample Output
  
  
1 2 3 1 2 3 4 5 6 7 8 9
 分析:
归并排序果题,归并排序是分治算法中的一类,其排序时间为0,有点跟二分相似,将数组一直均分,一直分到俩个数之间的距离为1或2
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>

#define maxn 1010 
using namespace std;
long long a[maxn],b[maxn];
int m;
void init()
{
	printf("%d",a[0]);
	for(int i=1;i<m;i++)
	printf(" %d",a[i]);
	printf("\n");
}

void merge(long long a[],int start,int mid,int end)
{
	int i=start,j=mid+1,k=start;
	while(i<=mid&&j<=end)
     {
     	if(a[i]<=a[j])
     	b[k++]=a[i++];
     	else
     	{
     		b[k++]=a[j++];
     	}
     }
     while(i<=mid)
     {
     	b[k++]=a[i++];
     }
     while(j<=end)
     {
     	b[k++]=a[j++];
     }
     for(int i=start;i<=end;i++)
     {
     	a[i]=b[i];
     }
}

void mergesort(long long a[],int start,int end)
{
	if(start<end)
	{
		int mid=(start+end)>>1;
		mergesort(a,start,mid);
		mergesort(a,mid+1,end);
		merge(a,start,mid,end);
	} 
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&m);
		for(int i=0;i<m;i++)
		scanf("%d",a+i);
		mergesort(a,0,m-1);
	    init();
	}
	return 0;
}

f
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值