G - Coins-------多重背包

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4


这道题是多重背包的题:

这道题的大意是给你n,m,m代表总价值,接下来2n个数,a1,a2,a3,....an代表价值,c1,c2,c3代表个数。求出从1到m中有多少个可以凑出多少种价值;

思路:我们将多重背包拆分成01背包和完全背包,再用二进制优化,所谓用二进制优化,其实就是将ci拆分成1,2,。。。。

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
using namespace std;
#define mx 100004
#define mm 104
#define inff -0x3fffffff
int n,m;
int dp[mx];
int val[mm],ant[mm];
void onezeropack(int va ,int we)
{
    int i;
    for(i=m;i>=we;i--)
    {
        if(dp[i]>=dp[i-we]+va)
            dp[i]=dp[i];
        else dp[i]=dp[i-we]+va;     // 不能用max函数直接来写,不然就会超时,我就是死在这里很多次
    }
       // dp[i]=max(dp[i],dp[i-we]+va);
}


void complepack(int va,int we)
{
    int i;
    for(i=we;i<=m;i++)
    {
        if(dp[i]>=dp[i-we]+va)
            dp[i]=dp[i];
        else dp[i]=dp[i-we]+va;
    }

     //   dp[i]=max(dp[i],dp[i-we]+va);
}


void multipack(int va,int we,int cnt)
{
    if(cnt*va>=m)
    {
        complepack(va,we);
        return;
    }
    else
    {
        int f=1;


        while(f<cnt)
        {
            onezeropack(f*va,f*we);
            cnt-=f;
            f=f*2;
        }

二进制优化


        onezeropack(cnt*va,cnt*we);   //这里是为了cnt的查漏补缺
    }
}
int main()
{
    int i,j;
    while(scanf("%d %d",&n,&m)&&m+n)
    {
        for(i=0;i<=m;i++)
        {
            dp[i]=inff;
        }
        dp[0]=0;                       //这里随意附一个值就是了,因为这里只用求种类
        for(i=0;i<n;i++)
            scanf("%d",&val[i]);
        for(i=0;i<n;i++)
            scanf("%d",&ant[i]);
        for(i=0;i<n;i++)
                multipack(val[i],val[i],ant[i]);


        int ans=0;
        for(i=1;i<=m;i++)
            if(dp[i]>0)
            ans++;
        printf("%d\n",ans);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值