poj3273 Monthly Expense 解题报告

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤
moneyi ≤ 10,000) that he will need to spend each day over the next
N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactlyM (1 ≤ 
M
 ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers:  N and
M 
Lines 2.. N+1: Line  i+1 contains the number of dollars Farmer John spends on the
ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

思路:利用二分法。首先确定二分范围,下界是他们中最大值(刚刚一个一组),上界是总和(全部在一组),然后判断这个值符不符合条件.符合条件则left+1,否则right+mid,直至上界等于下界

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n, m, f[100005];
int pd(int t)
{
    int i, count=1, tmp=0;
    for(i=0; i<n; i++)
    {
        tmp+=f[i];
        if(tmp>t)
        {
            count++;
            tmp=f[i];
        }
    }
    
    if(count>m) return 1;//不用等于是因为此时的mid满足条件,只是不够最优
    return 0;
}
int main()
{
    while(scanf("%d%d", &n, &m)!=EOF)
    {
        int i, sum=0, max=0;
        memset(f, 0, sizeof(f));
        for(i=0; i<n; i++)
        {
            scanf("%d", &f[i]);
            sum+=f[i];
            max=max>f[i]?max:f[i];
        }
        int left=max, right=sum;
        while(left<right)
        {
            int mid=left+(right-left)/2;
            if(pd(mid))
                left=mid+1;
            else
                right=mid;
        }
        printf("%d\n", left);
    }
}




  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值