ACM: 一题二分搜索题 poj3273    (…

                                                                Monthly Expense

 

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ MN) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5

100

400

300

100

500

101

400

Sample Output

500

题意: 给出连续的n天里面 farm 的消费.  现在要做一个"fajomonths" 把它分成m份, 并且每一
     份在时间上是连续的.

思路:
         1.  暴力搜索.  (超时 T.T )
         2.  网上搜索下结果,发现二分法求解.
         3.  二分法思路:  
                           (1). 先确定二分的上界 和 下界.   (  n(max)   ~~~ ∑n(i) )
                           (2). 开始二分夹逼  (判断界限的条件是: 是否满足分块为m) .

AC代码:

#include <iostream>
#include <cstdio>
using namespace std;
#define MAX 100010

int n , m;
int a[MAX];

void find(int &left,int &right)
{
    left = 0;
    right = 0;
    int i ;
    for(i = 0; i < n; ++i)
    {
        if(left < a[i])
            left = a[i];
        right += a[i];
    }
}

int legalPartition(int ans)
{
    int part = 0;
    int i ;
    int k = 0;
    for(i = 0; i < n; ++i)
    {
        if(part + a[i] > ans)
        {
            part = a[i];
            ++k;
        }
        else
        {
            part += a[i];
        }
    }
    k++;
    if(k > m) return 0;
    else return 1;
}

int result(int &left,int &right)
{
    int mid = 0;
    while(left < right)
    {
        mid = (right + left) / 2;
        if( legalPartition(mid) == 0 )
            left = mid + 1;
        else
            right = mid;
    }
    
    return left;
}

int main()
{
    while(cin >> n >> m)
    {
        int left , right;
        int i , j;
        for(i = 0; i < n; ++i)
        {
            cin >> a[i];
        }
        find(left,right);
        cout << result(left,right) << endl;
    }
    
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值