zoj 3204 Connect them(kruskal算法) 解题报告

Time Limit: 1000MS Memory Limit: 32768KB 64bit IO Format: %lld & %llu

 Status

Description

You have n computers numbered from 1 to n and you want to connect them to make a small local area network (LAN). All connections are two-way (that is connecting computers i and j is the same as connecting computers jand i). The cost of connecting computer i and computer j is cij. You cannot connect some pairs of computers due to some particular reasons. You want to connect them so that every computer connects to any other one directly or indirectly and you also want to pay as little as possible.

Given n and each cij , find the cheapest way to connect computers.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 100), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains an integer n (1 < n <= 100). Then n lines follow, each of which contains n integers separated by a space. The j-th integer of the i-th line in these n lines is cij, indicating the cost of connecting computers i and j (cij = 0 means that you cannot connect them). 0 <= cij <= 60000, cij = cjicii = 0, 1 <= ij <= n.

Output

For each test case, if you can connect the computers together, output the method in in the following fomat:

i1j1i1j1 ......

where ikik (k >= 1) are the identification numbers of the two computers to be connected. All the integers must be separated by a space and there must be no extra space at the end of the line. If there are multiple solutions, output the lexicographically smallest one (see hints for the definition of "lexicography small") If you cannot connect them, just output "-1" in the line.

Sample Input

2
3
0 2 3
2 0 5
3 5 0
2
0 0
0 0

Sample Output

1 2 1 3
-1

Hints:
A solution A is a line of p integers: a1a2, ...ap.
Another solution B different from A is a line of q integers: b1b2, ...bq.
A is lexicographically smaller than B if and only if:
(1) there exists a positive integer r (r <= pr <= q) such that ai = bi for all 0 < i < r and ar < br
OR
(2) p < q and ai = bi for all 0 < i <= p

Source

The 6th Zhejiang Provincial Collegiate Programming Contest

水题一枚,就是利用kruscal,然后注意排序就好

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int f[10100];
#define INF 0x3f3f3f
int find(int x)
{
    return f[x]==x?(x):(f[x]=find(f[x]));
}

struct zc
{
    int a,b,c;
}r[11000];

struct ans//存结果
{
    int a,b;
}an[11000];

int anst;

int cmp(zc a,zc b)
{
    if(a.c!=b.c)return a.c<b.c;
    if(a.a!=b.a)return a.a<b.a;
    return a.b<b.b;
}

int merge(int x,int y,int i)
{
    x=find(x);
    y=find(y);
    if(x!=y)
    {
        f[x]=y;
        an[anst].a=r[i].a;
        an[anst++].b=r[i].b;
        return 1;
    }
    return 0;
}

int cmp1(ans a,ans b)
{
    if(a.a!=b.a)return a.a<b.a;
    else return a.b<b.b;
}

int main()
{
    int T,n,a,b,c;
    scanf("%d",&T);
    while(T--)
    {
        anst=0;
        scanf("%d",&n);
        for(int i=0;i<10010;i++)
        {
            f[i]=i;
        }
        int t=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&c);
                if(j<=i||c==0)continue;
                r[t].a=i;
                r[t].b=j;
                r[t++].c=c;
            }
        }
        sort(r,r+t,cmp);
        int sum=0;
        int flag=0;
        for(int i=0;i<t;i++)
        {
            if(merge(r[i].a,r[i].b,i))
                sum++;
            if(sum==n-1){flag=1;break;}
        }
        if(!flag)
            printf("-1\n");
        else
        {
            sort(an,an+anst,cmp1);
            for(int i=0;i<anst-1;i++)
            {
                printf("%d %d ",an[i].a,an[i].b);
            }
            printf("%d %d\n",an[anst-1].a,an[anst-1].b);
        }

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值