poj 3259 Wormholes spfa判断负环 解题报告

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

思路:

m个双向正边,w个单向负边。大意就是判断有无负环(能够通过虫洞看到以前的自己)。注意数据中有重复边,使用小的就可。

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
#define INF 0x3f3f3f3f
#define MAXN 550

int n,m,w,vis[MAXN],map[MAXN][MAXN],dis[MAXN];

int spfa(int s)
{
    int cs[MAXN]={0};
    memset(dis,0x3f,sizeof(dis));
    vis[s]=1;
    dis[s]=0;
    queue<int> Q;
    Q.push(s);
    while(!Q.empty())
    {
        int t=Q.front();
        Q.pop();
        //判断负环
        cs[t]++; if(cs[t]>n) return 0;
        vis[t]=0;
        for(int i=1;i<=n;i++)
        {
            if(dis[i]>dis[t]+map[t][i])
            {
                dis[i]=dis[t]+map[t][i];
                if(!vis[i])
                {
                    vis[i]=1;
                    Q.push(i);
                }
            }
        }
    }
    return 1;
}


int main()
{
    int a,b,c,T;
    scanf("%d",&T);
    while(T--)
    {
        memset(vis,0,sizeof(vis));
        memset(map,0x3f,sizeof(map));
        scanf("%d%d%d",&n,&m,&w);
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            //坑,有重边问题,走小的
            if(map[a][b]>c)
                map[a][b]=map[b][a]=c;
        }
        for(int i=0;i<w;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            map[a][b]=-c;
        }
        if(spfa(1)==0)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值