hdu 4751 Divide Groups bfs 搜索 解题报告

Divide Groups

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1969    Accepted Submission(s): 708


Problem Description

  This year is the 60th anniversary of NJUST, and to make the celebration more colorful, Tom200 is going to invite distinguished alumnus back to visit and take photos.
  After carefully planning, Tom200 announced his activity plan, one that contains two characters:
  1. Whether the effect of the event are good or bad has nothing to do with the number of people join in.
   2. The more people joining in one activity know each other, the more interesting the activity will be. Therefore, the best state is that, everyone knows each other.
  The event appeals to a great number of alumnus, and Tom200 finds that they may not know each other or may just unilaterally recognize others. To improve the activities effects, Tom200 has to divide all those who signed up into groups to take part in the activity at different time. As we know, one's energy is limited, and Tom200 can hold activity twice. Tom200 already knows the relationship of each two person, but he cannot divide them because the number is too large.
  Now Tom200 turns to you for help. Given the information, can you tell if it is possible to complete the dividing mission to make the two activity in best state.
 

Input
  The input contains several test cases, terminated by EOF.
  Each case starts with a positive integer n (2<=n<=100), which means the number of people joining in the event.
  N lines follow. The i-th line contains some integers which are the id
of students that the i-th student knows, terminated by 0. And the id starts from 1.
 

Output
  If divided successfully, please output "YES" in a line, else output "NO".
 

Sample Input
  
  
3 3 0 1 0 1 2 0
 

Sample Output
  
  
YES
 

题意:将n个人分成两组,使得每组中的每个人都认识剩余所有人。 

思路:

首先,只保留两个都认识的边,vis标记分组,0组与1组。

然后,bfs扫一遍,遇到矛盾的就直接NO。

代码:

#include <iostream>
#include <cstring>
#include <string>
#include <queue>
#include <cstdio>
#include <algorithm>
using namespace std;

int n, t;
int z[110][110], vis[110];

int bfs(int s)
{
    queue<int>Q;
    Q.push(s);
    vis[s] = 1;
    while(!Q.empty())
    {
        int now = Q.front();
        Q.pop();
        for(int i = 1; i <= n; i++)
        {
            if(z[now][i] == 1 || now == i) continue;
            if(vis[i] == -1)
            {
                vis[i] = 1 - vis[now];
                Q.push(i);
            }
            else if(vis[i] == vis[now])
                return 0;
        }
    }
    return 1;
}

int main()
{
    int i;
    while(scanf("%d", &n) != EOF)
    {
        memset(z, 0, sizeof(z));
        memset(vis, -1, sizeof(vis));
        for(i = 1; i <= n; i++)
        {
            while(scanf("%d", &t), t)
                z[i][t] = 1;
        }
        //如果不是相互认识,都改为不认识
        for(i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++)
                if(!z[i][j]) z[j][i] = 0;
        for(i = 1; i <= n; i++)
        {
            if(vis[i] != -1) continue;
            if(!bfs(i)) break;
        }
        if(i <= n) printf("NO\n");
        else printf("YES\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值