PAT (Advanced Level) 1102. Invert a Binary Tree (25) 解题报告

20 篇文章 0 订阅
9 篇文章 0 订阅

1102. Invert a Binary Tree (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node from 0 to N-1, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1


题意:给定一个二叉树,求翻转后的层次与中序遍历

思路:前序用队列,中序用递归

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#include <cmath>
#include <algorithm>
using namespace std;

int lchild[10], rchild[10], vis[10]={0};
queue<int> tree;
int cnt = 0, n;

int inorder(int a)
{
    if(lchild[a] != -1) inorder(lchild[a]);
    cnt++;
    printf("%d", a);
    if(cnt < n) printf(" ");
    if(rchild[a] != -1) inorder(rchild[a]);
}

int main()
{
    char l, r;
    scanf("%d", &n);
    getchar();
    for(int i = 0; i < 10; i++)
        lchild[i] = rchild[i] = -1;

    for(int i = 0; i < n; i++)
    {
        scanf("%c %c", &l, &r);
        getchar();
        if(l != '-')
        {
            rchild[i] = l - '0';
            vis[l - '0'] = 1;
        }
        if(r != '-')
        {
            lchild[i] = r - '0';
            vis[r - '0'] = 1;
        }
    }
    int root = 0;
    for(int i = 0; i < n; i++)
        if(vis[i] == 0) root = i;
    tree.push(root);
    while(!tree.empty())
    {
        if(lchild[tree.front()] != -1) tree.push(lchild[tree.front()]);
        if(rchild[tree.front()] != -1) tree.push(rchild[tree.front()]);
        printf("%d", tree.front());
        tree.pop();
        if(!tree.empty()) printf(" ");
    }
    printf("\n");
    inorder(root);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值