PAT (Advanced Level) 1103. Integer Factorization (30) 解题报告

21 篇文章 0 订阅

1103. Integer Factorization (30)

时间限制
1200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + ... nK^P

where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112 + 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output "Impossible".

Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible
思路:剪枝,dfs

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#include <cmath>
#include <algorithm>
#include <vector>
using namespace std;

int n, k, p, nowSum = 0;
int ans[500], flag = 0;

int mypow(int n, int cs)
{
    int sum = 1;
    for(int i = 0; i < cs; i++)
        sum *= n;
    return sum;
}

void dfs(int now, int cur, int *vec)
{
    if(cur == k)
    {
        if(now != 0) return;
        int sum = 0;
        for(int i = 0; i < k; i++)
            sum += vec[i];
        if(sum >= nowSum)
        {
            for(int i = 0; i < k; i++)
                ans[i] = vec[i];
            nowSum = sum;
            flag = 1;
        }
        return;
    }
    int upper = sqrt(now);
    int lower = cur > 0 ? vec[cur-1] : 1;
    for(int i = lower; i <= upper; i++)
    {
        int res = mypow(i, p);
        if(now >= res)
        {
            vec[cur] = i;
            dfs(now - res, cur + 1, vec);
        }
        else return;
    }
}

int main()
{
    int vec[500];
    scanf("%d%d%d", &n, &k, &p);
    dfs(n, 0, vec);
    if(flag)
    {
        printf("%d = %d^%d", n, ans[k-1], p);
        for(int i = k-2; i >= 0; i--)
            printf(" + %d^%d", ans[i], p);
        printf("\n");
    }
    else printf("Impossible\n");
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值