1006. Sign In and Sign Out (25)(C++)

1006. Sign In and Sign Out (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133

大致题意:给出所有人进入机房和离开机房的时间,然后判断第一个进入的人和最后一个进入的人。

思路:可以将时间全部转换为秒,然后比较大小。(另一思路:可以把整个时间当作一个字符串,用函数strcmp()比较 )

#include <iostream>
#include <cstring>
using namespace std;

int main(){
	char ID[16];
	int m;
	int ih,im,is,oh,om,os;      //进入和退出的时间 
	int isum=0,osum=0;
	int ist=24*3600+59*60+59,ost=0;    //进入和退出的时间节点,用于比较 
	char IDIn[16],IDOut[16];
	scanf("%d",&m);
	for(int i=0; i<m; ++i){
		scanf("%s %d:%d:%d %d:%d:%d",&ID,&ih,&im,&is,&oh,&om,&os);
		isum=ih*3600+im*60+is;      //全部转换为秒 
		osum=oh*3600+om*60+os;
		if(isum<osum){            //进入时间必须小于退出时间 
			if(isum<ist){         //进入时间比较        
				ist=isum; 
				strcpy(IDIn,ID);  //字符串赋值 
			}
			if(osum>ost){         //退出时间比较 
				ost=osum;
				strcpy(IDOut,ID);
			}
		}
	}
	printf("%s %s\n",IDIn,IDOut);
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值