1006. Sign In and Sign Out (25)(C++)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题目大意:输入几个人的离开和进入时间,找出最早进入和最晚离开的人。

解题思路:用秒统一单位即可。

#include<iostream>
#include<string>
using namespace std;
int main(){
    string s1,s2;
    int n,max=0,min=86400;
    cin>>n;
    for(int i=0;i<n;i++){
        string stu;
        int h1,h2,m1,m2,se1,se2,t1,t2;
        cin>>stu;
        scanf("%d:%d:%d %d:%d:%d",&h1,&m1,&se1,&h2,&m2,&se2);
        t1=3600*h1+60*m1+se1;
        t2=3600*h2+60*m2+se2;
        if(t1<min){
            s1=stu;min=t1;
        }
        if(t2>max){
            s2=stu;max=t2;
        }
    }
    cout<<s1<<' '<<s2;
}

另外直接对时间那一个字符串进行比较也是可以的。

#include <iostream>
#include <string>
using namespace std;
string ansEarly, ansLate, early = "24:00:00", late = "00:00:00";
int main(){
	 int n;
	 scanf("%d",&n);
	 for(int i = 0; i < n; ++ i){
	 	string temp, tempIn, tempOut;
	 	cin>>temp>>tempIn>>tempOut;
	 	if(tempIn < early){
	 		ansEarly = temp;
	 		early = tempIn;
		}	
	 	if(tempOut > late){
	 		ansLate = temp;
	 		late = tempOut;
		}
	 }
	 printf("%s %s", ansEarly.c_str(), ansLate.c_str());
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
下面是使用 WinHttp 访问 https://www.amazon.com.au/ap/signin 的示例代码: ```cpp #include <windows.h> #include <winhttp.h> #include <iostream> #pragma comment(lib, "winhttp.lib") int main() { HINTERNET hSession = NULL, hConnect = NULL, hRequest = NULL; // 初始化 WinHttp hSession = WinHttpOpen(L"WinHTTP Example/1.0", WINHTTP_ACCESS_TYPE_DEFAULT_PROXY, WINHTTP_NO_PROXY_NAME, WINHTTP_NO_PROXY_BYPASS, 0); if (!hSession) { std::cout << "Failed to open WinHttp session." << std::endl; return 1; } // 建立连接 hConnect = WinHttpConnect(hSession, L"www.amazon.com.au", INTERNET_DEFAULT_HTTPS_PORT, 0); if (!hConnect) { std::cout << "Failed to connect to server." << std::endl; WinHttpCloseHandle(hSession); return 1; } // 创建请求 hRequest = WinHttpOpenRequest(hConnect, L"GET", L"/ap/signin", NULL, WINHTTP_NO_REFERER, WINHTTP_DEFAULT_ACCEPT_TYPES, WINHTTP_FLAG_SECURE); if (!hRequest) { std::cout << "Failed to create request." << std::endl; WinHttpCloseHandle(hConnect); WinHttpCloseHandle(hSession); return 1; } // 发送请求 if (!WinHttpSendRequest(hRequest, WINHTTP_NO_ADDITIONAL_HEADERS, 0, WINHTTP_NO_REQUEST_DATA, 0, 0, 0)) { std::cout << "Failed to send request." << std::endl; WinHttpCloseHandle(hRequest); WinHttpCloseHandle(hConnect); WinHttpCloseHandle(hSession); return 1; } // 等待响应 if (!WinHttpReceiveResponse(hRequest, NULL)) { std::cout << "Failed to receive response." << std::endl; WinHttpCloseHandle(hRequest); WinHttpCloseHandle(hConnect); WinHttpCloseHandle(hSession); return 1; } // 读取响应内容 DWORD dwSize = 0, dwDownloaded = 0; LPSTR pszOutBuffer = NULL; do { // 确定缓冲区大小 dwSize += 4096; pszOutBuffer = (LPSTR)realloc(pszOutBuffer, dwSize); if (!pszOutBuffer) { std::cout << "Out of memory." << std::endl; WinHttpCloseHandle(hRequest); WinHttpCloseHandle(hConnect); WinHttpCloseHandle(hSession); return 1; } // 读取响应内容 ZeroMemory(pszOutBuffer + dwDownloaded, 4096); if (!WinHttpReadData(hRequest, pszOutBuffer + dwDownloaded, 4096, &dwDownloaded)) { std::cout << "Failed to read data." << std::endl; WinHttpCloseHandle(hRequest); WinHttpCloseHandle(hConnect); WinHttpCloseHandle(hSession); return 1; } } while (dwDownloaded > 0); // 输出响应内容 std::cout << pszOutBuffer << std::endl; // 释放资源 free(pszOutBuffer); WinHttpCloseHandle(hRequest); WinHttpCloseHandle(hConnect); WinHttpCloseHandle(hSession); return 0; } ``` 这段代码使用 WinHttp 库中的函数建立与 Amazon 网站的 HTTPS 连接,并发送 GET 请求获取登录页面。注意,这段代码使用了 C++11 中的 auto 关键字来自动推导变量类型,如果你的编译器不支持 C++11,可以将 auto 改为显式的类型。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值