1009. Product of Polynomials (25)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
This time, you are supposed to find A*B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
This time, you are supposed to find A*B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
#include<iostream>
#include<stdio.h>
#include<vector>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
int main()
{
int K; pair<int, double> p;
vector<pair<int, double> > v1,v2,v,vss;
cin >> K;
set<int> s; vector<int> vs;
for (int i = 0; i < K; i++)
{
cin >> p.first >> p.second;
v1.push_back(p);
}//把指数和系数当成一对加入到容器中,下同
cin >> K;
for (int i = 0; i < K; i++)
{
cin >> p.first >> p.second;
v2.push_back(p);
}
for (int k = 0; k < v1.size(); k++)
{
for (int m = 0; m < v2.size(); m++)
{
p.first = v1[k].first + v2[m].first;
p.second = v1[k].second *v2[m].second;
if (p.second)
{
v.push_back(p);
s.insert(p.first);
}
}
}
for (set<int>::iterator it = s.begin(); it != s.end(); it++)
{
vs.push_back(*(it));
}
reverse(vs.begin(),vs.end());
double sum = 0;
for (int j = 0; j < vs.size(); j++)
{
sum = 0;
for (int i = 0; i < v.size(); i++)
{
if (v[i].first == vs[j])
{
p.first = vs[j];
sum += v[i].second;
}
}
p.second = sum;
if(sum)//我被坑在这里了,要注意到合并同类项时可能系数为0
vss.push_back(p);
}
cout << vss.size();
for (int k = 0; k < vss.size(); k++)
{
//cout << v[k].first << " " << v[k].second;
printf(" %d %.1f", vss[k].first, vss[k].second);//控制格式
}
v.clear(); v1.clear(); v2.clear(); vss.clear(); s.clear(); vs.clear();
}