poj 2411&&hdu 1400 Mondriaan's Dream(状压DP)

37 篇文章 0 订阅
16 篇文章 0 订阅

Problem Description

Squares and rectangles fascinated the famous Dutch painter PietMondriaan. One night, after producing the drawings in his 'toilet series'(where he had to use his toilet paper to draw on, for all of his paper wasfilled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.

1021


Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2

1 3

1 4

2 2

2 3

2 4

2 11

4 11

0 0

Sample Output

1

0

1

2

3

5

144

51205

解法:

用2进制的01表示放和不放,那么按照矩形的摆放的形式,我们知道当前行只会受到上方一行的影响。设dp[i][j]表示第i行处于状态j的时候,共有多少种放置方法。dp[i][j]=sum(dp[i-1][k]),其中状态j和k要能共存,并且j和k要使得第i-1行刚好铺满。


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int cnt, stk[150];
long long dp[15][2050];
int n, m;
bool ok(int n, int x){
	int i = 0;
	while (i < n){
		if (x & (1 << i)) i++;
		else{
			if (x & (1 << (i + 1))) return 0;
			if (i == n - 1) return 0;
			i += 2;
		}
	}
	return 1;
}
void findStk()
{
	for (int i = 0; i < (1 << m); i++)
		if (ok(m, i))
			stk[cnt++] = i;
}
int main(){
	int r, i, k;
	while (scanf("%d%d", &n, &m), n + m)
	{
		memset(dp, 0, sizeof(dp));
		cnt = 0;
		findStk();
		for (i = 0; i < cnt; i++)
			dp[0][stk[i]] = 1;
		for (r = 1; r <n; r++)
			for (i = 0; i < cnt; i++){
			for (k = 0; k < (1 << m); k++){
				if ((stk[i] & k) != k) continue;
				dp[r][stk[i] ^ k] += dp[r - 1][k];
			}
			}
		printf("%lld\n", dp[n - 1][0]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值