poj 3067 Japan(求逆序对)

37 篇文章 0 订阅
3 篇文章 0 订阅

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

solution:

先将X排序,x相同的话,给y排,然后逆序对就是相交的个数

#include <iostream>
#include <stdio.h>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 10000005
int n, c[maxn], x, y;
struct node
{
	int l, r, id;
} a[maxn];
int cmp(node a, node b)
{
	if (a.l != b.l)return a.l<b.l;
	return a.r<b.r;
}
int sum(int x)
{
	int ans = 0;
	while (x>0)
	{
		ans += c[x];
		x -= x&-x;
	}
	return ans;
}
void add(int x, int d)
{
	while (x <= y)
	{
		c[x] += d;
		x += x&-x;
	}
}
int main()
{
	int i, j, k, l, r, t, cc= 1;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d%d%d", &x, &y, &n);
		memset(c, 0, sizeof(c));
		for (i = 1; i <= n; i++)
		{
			scanf("%d%d", &a[i].l, &a[i].r);
		}
		sort(a + 1, a + 1 + n, cmp);
		long long ans = 0;
		for (i = 1; i <= n; i++)
		{
			add(a[i].r, 1);
			ans += sum(y) - sum(a[i].r);
		}
		printf("Test case %d: %lld\n", cc++, ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值