Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16009 Accepted Submission(s): 11292
Problem Description
“Well, it seems the first problem is too easy. I will let you know how foolish you are later.” feng5166 says.
“The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+…+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that “4 = 3 + 1” and “4 = 1 + 3” is the same in this problem. Now, you do it!”
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627
简单DP就行,dp[i][j]表示对i划分最大数不超过j时的方法数。初始时当i= 0这不管怎么分都是1种,如果j = 1,则不管怎么分也是一种(即全是1,i*1 = i)。主要的转移方程为dp[i][j] = dp[i][j-1]+dp[i-j][j]。又有当j>i时,dp[i][j] = dp[i][i]。当i>=j时,dp[i][j]得从已有的元素中推出。所以考虑不加j时有dp[i][j-1]种方法,而 dp[i-j][j] 加了 j 后即为最高为为j的所有排列,两者之和即为dp[i][j].
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
int dp[200][200];
int main()
{
int i,j;
for(i = 0;i<121;i++) dp[0][i] = 1;
for(i = 0;i<121;i++) dp[i][1] = 1;
for(i = 1;i<121;i++)
for(j = 2;j<121;j++){
if(i<j)
dp[i][j] = dp[i][j-1];
else
dp[i][j] = dp[i][j-1] + dp[i-j][j];
}
int n;
while(scanf("%d",&n)!=EOF)
printf("%d\n",dp[n][n]);
return 0;
}