poj 1426 数学推理找规律

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 22719 Accepted: 9362 Special Judge
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input

2
6
19
0
Sample Output

10
100100100100100100
111111111111111111

题意:
输入一个不超过200的n,输出一个只有0和1组成的十进制数,使之为n的倍数

解法:
此题放到BFS里,可的确没看出来哪里用到宽搜了。 。我的做法是开一个较大的数组G[i],i代表这把这个只有0和1的十进制数看成是一个二进制数然后把这个二进制数转成十进制数,而G[i]即是这个只有0和1的十进制数对n取的余数,如当n = 6,则G[7] = 2(7 = 111,111%6 = 3),
当我们枚举生成所有情况的时候,可以看到每一个节点除了最后一个数字外(最后一个数字当节点数是奇数时为1,是偶数时为0),和父亲节点是一样的,那么,根据同余模定理可以有递推公式G[i] = (10*G[i/2] + i%2)%n.这样,当G[i]为0时可以判断找到这个数,然后将十进制的i变为二进制数输出即可。由此我觉得此题应该是个数学题。 。
从这个树

#include <cstdio>
#include <iostream>
#include <stack>

using namespace std;
int G[50000000];
stack<int>st;
int main(){
    int n;
    while(scanf("%d",&n)&&n){
        int i;
        G[1] = 1;
        for(i = 2;G[i-1];i++)
            G[i] = (10*G[i/2] + i%2)%n;
        i--;
        while(i){
            int c = i&1;
            st.push(c);
            i >>= 1;
        }
        while(!st.empty()){
            printf("%d",st.top());
            st.pop();
        }
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值