Dungeon Master
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22001 Accepted: 8568
Description
You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.
Is an escape possible? If yes, how long will it take?
Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a ‘.’. Your starting position is indicated by ‘S’ and the exit by the letter ‘E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).
where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!
Sample Input
3 4 5
S….
.###.
.##..
# # #.#
# # # ##
# ####
# #.##
# #…
# # # ##
#####
#.###
####E
1 3 3
S##
# E #
# # #
0 0 0
Sample Output
Escaped in 11 minute(s).
Trapped!
题意:
在一个空间里有一个牢笼,你只能上下左右前后的走,问最短从S到E的步数,直接BFS,用一个三维数组就好。
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
using namespace std;
typedef struct{
int sx,sy,sh;
int sum;
}Po;
char G[35][35][35];
int dp[35][35][35];
int h,m,n;
Po move[] = {0,0,-1,0, 0,0,1,0, 0,-1,0,0, 0,1,0,0, 1,0,0,0, -1,0,0,0 };
queue<Po>qu;
bool IsTrue(Po a){
if(G[a.sh][a.sx][a.sy] == '#')
return false;
if(a.sh<0||a.sh>=h)
return false;
if(a.sx<0||a.sx>=m)
return false;
if(a.sy<0||a.sy>=n)
return false;
return true;
}
int dfs(Po S){
int i;
qu.push(S);
while(!qu.empty()){
Po ter = qu.front();qu.pop();
for(i = 0;i<6;i++){
Po term = ter;
term.sx += move[i].sx;
term.sy += move[i].sy;
term.sh += move[i].sh;
if(IsTrue(term)){
term.sum++;
qu.push(term);
if(G[term.sh][term.sx][term.sy] == 'E'){
return term.sum;
}
G[term.sh][term.sx][term.sy] = '#';
}
}
}
return -1;
}
int main()
{
// freopen("data.in","r",stdin);
while(scanf("%d%d%d",&h,&m,&n)!=EOF&&(h||m||n)){
getchar();
memset(dp,-1,sizeof(dp));
int i,j,k;
Po S,E;
for(i = 0;i<h;i++){
for(j = 0;j<m;j++){
for(k = 0;k<n;k++){
char ch;
ch = getchar();
G[i][j][k] = ch;
if(G[i][j][k] == 'S'){
S.sh = i;
S.sx = j;
S.sy = k;
G[i][j][k] = '#';
}
if(G[i][j][k] == 'E'){
E.sh = i;
E.sx = j;
E.sy = k;
}
}
getchar();
}
getchar();
}
while(!qu.empty())qu.pop();
S.sum = 0;
int kk = dfs(S);
if(kk == -1)
printf("Trapped!\n");
else
printf("Escaped in %d minute(s).\n",kk);
}
return 0;
}