POJ 1416 暴搜

Shredding Company
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4760 Accepted: 2746
Description

You have just been put in charge of developing a new shredder for the Shredding Company Although a “normal” shredder would just shred sheets of paper into little pieces so that the contents would become unreadable, this new shredder needs to have the following unusual basic characteristics.

1.The shredder takes as input a target number and a sheet of paper with a number written on it.

2.It shreds (or cuts) the sheet into pieces each of which has one or more digits on it.

3.The sum of the numbers written on each piece is the closest possible number to the target number, without going over it.

For example, suppose that the target number is 50, and the sheet of paper has the number 12346. The shredder would cut the sheet into four pieces, where one piece has 1, another has 2, the third has 34, and the fourth has 6. This is because their sum 43 (= 1 + 2 + 34 + 6) is closest to the target number 50 of all possible combinations without going over 50. For example, a combination where the pieces are 1, 23, 4, and 6 is not valid, because the sum of this combination 34 (= 1 + 23 + 4 + 6) is less than the above combination’s 43. The combination of 12, 34, and 6 is not valid either, because the sum 52 (= 12 + 34 + 6) is greater than the target number of 50.

Figure 1. Shredding a sheet of paper having the number 12346 when the target number is 50

There are also three special rules :

1.If the target number is the same as the number on the sheet of paper, then the paper is not cut.

For example, if the target number is 100 and the number on the sheet of paper is also 100, then

the paper is not cut.

2.If it is not possible to make any combination whose sum is less than or equal to the target number, then error is printed on a display. For example, if the target number is 1 and the number on the sheet of paper is 123, it is not possible to make any valid combination, as the combination with the smallest possible sum is 1, 2, 3. The sum for this combination is 6, which is greater than the target number, and thus error is printed.

3.If there is more than one possible combination where the sum is closest to the target number without going over it, then rejected is printed on a display. For example, if the target number is 15, and the number on the sheet of paper is 111, then there are two possible combinations with the highest possible sum of 12: (a) 1 and 11 and (b) 11 and 1; thus rejected is printed. In order to develop such a shredder, you have decided to first make a simple program that would simulate the above characteristics and rules. Given two numbers, where the first is the target number and the second is the number on the sheet of paper to be shredded, you need to figure out how the shredder should “cut up” the second number.

Input

The input consists of several test cases, each on one line, as follows :

tl num1
t2 num2

tn numn
0 0

Each test case consists of the following two positive integers, which are separated by one space : (1) the first integer (ti above) is the target number, (2) the second integer (numi above) is the number that is on the paper to be shredded.

Neither integers may have a 0 as the first digit, e.g., 123 is allowed but 0123 is not. You may assume that both integers are at most 6 digits in length. A line consisting of two zeros signals the end of the input.

Output

For each test case in the input, the corresponding output takes one of the following three types :

sum part1 part2 …
rejected
error

In the first type, partj and sum have the following meaning :

1.Each partj is a number on one piece of shredded paper. The order of partj corresponds to the order of the original digits on the sheet of paper.

2.sum is the sum of the numbers after being shredded, i.e., sum = part1 + part2 +…

Each number should be separated by one space.
The message error is printed if it is not possible to make any combination, and rejected if there is
more than one possible combination.
No extra characters including spaces are allowed at the beginning of each line, nor at the end of each line.
Sample Input

50 12346
376 144139
927438 927438
18 3312
9 3142
25 1299
111 33333
103 862150
6 1104
0 0
Sample Output

43 1 2 34 6
283 144 139
927438 927438
18 3 3 12
error
21 1 2 9 9
rejected
103 86 2 15 0
rejected
Source

题意:
将一个个整数a分开,如将12346分成1 2 34 6,使得分开后的数相加(1+2+34+6=43)与n的差最小且不能超过n,如果一开始a=n那么不能分割,如果最大的不止一组解输出rejected。如果不能满足条件,如123不管怎么分都比1大,输出error,其余输出最优解和分割方法。

解法:
先是考虑搜索加剪枝,后来觉得这数据量直接暴搜也能过,就随手写了个暴搜交了。 。结果耗时0ms。 。就懒得再剪枝优化了。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <stack>

using namespace std;

int G[10000000];
int G1[10000000];

int cnt(int k){
    int sum = 0;
    while(k){
        sum++;
        k/=10;
    }
    return sum;
}

void make(int k,int n){
    stack<int>tem;
    while(k){
        int c = k%10;
        k/=10;
        tem.push(c);
    }
    int i;
    for(i = 0;i<n;i++){
        G[i] = tem.top();
        tem.pop();
    }
}

int Sum(int s,int e){
    int sum = 0;;
    for(;s<e;s++) sum+=G1[s];
    return sum;
}


int main(){
//    freopen("data.in","r",stdin);
//    freopen("data.out","w",stdout);
    int N,a;
    while(scanf("%d%d",&N,&a)&&(N||a)){
        int cntdi = cnt(a);
        make(a,cntdi);
        int i,j,k,made;
        int Max = -0x3f3f3f3f,PP = 0,p,tem;

        for(i = 0;i<1<<(cntdi-1);i++){

            tem = G[0];
            p = 0;
            for(j = 1,k = 1;j<1<<(cntdi - 1);k++,j<<=1){
                if(j&i){
                    G1[p++] = tem;
                    tem = G[k];
                }else{
                    tem = tem*10 + G[k];
                }
            }
            G1[p++] = tem;
            int kk = Sum(0,p);
            if(kk<=N){
                if(kk>Max){
                    Max = kk;
                    made = i;
                    PP = 0;
                }
                else if(kk == Max) PP = 1;
            }
        }

        if(PP == 1) printf("rejected\n");
        else if(Max ==-0x3f3f3f3f) printf("error\n");
        else{
            printf("%d",Max);
            tem = G[0];
            p = 0;
            i = made;
            for(j = 1,k = 1;j<1<<(cntdi - 1);k++,j<<=1){
                if(j&i){
                    G1[p++] = tem;
                    tem = G[k];
                }else{
                    tem = tem*10 + G[k];
                }
            }
            G1[p++] = tem;
            for(k = 0;k<p;k++)printf(" %d",G1[k]);
            printf("\n");
        }

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值