POJ 1936 DP(公共序列+滚动数组)

All in All
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 30425 Accepted: 12657
Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.
Output

For each test case output “Yes”, if s is a subsequence of t,otherwise output “No”.
Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter
Sample Output

Yes
No
Yes
No

题意:
判断第一个串是不是第二个串的字串。
题解:
感觉这就是个求公共子序列的。 。但是长度太长。得用滚动。现在写这个公共序列的代码很快了。马上写了个。交了就1A了、用时16ms

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define SIZE 100000 + 10
#define f(i,a,b) for(int i = a;i<=b;i++)
#define fi(i,a,b) for(int i = a;i>=b;i--)
using namespace std;

char a[SIZE];
char b[SIZE];
int dp[2][SIZE];

int main()
{
//    freopen("data.in","r",stdin);
    while(scanf("%s %s",a+1,b+1)!=EOF){
        memset(dp,0,sizeof(dp));
        int old = 0,now = 1;
        int len1 = strlen(a+1);
        int len2 = strlen(b+1);
        f(i,1,len1){
            f(j,1,len2)
                if(a[i] == b[j])
                    dp[now][j] = dp[old][j-1]+1;
                else
                    dp[now][j] = max(dp[now][j-1],dp[old][j]);
            old^=1;
            now^=1;
        }
        if(dp[old][len2] == len1)
            printf("Yes\n");
        else
            printf("No\n");
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值