POJ3041 二分图最大匹配

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18385 Accepted: 10019

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input

  • Line 1: Two integers N and K, separated by a single space.
  • Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
    Output

  • Line 1: The integer representing the minimum number of times Bessie must shoot.
    Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

题意:
给出一个方阵,这个方阵里有一些点,每次操作可以让一行或者一列消去。问最少要操作几次可以让所有点都消失。
题解:
如果我们用V1集合放行的坐标,V2放列的坐标。那么V1到V2的一条变就是一个点。每次选了V1或者V2里的一个点即意味着那一行或者一列的所有点都没有了。那问题就变成了求V1和V2里的最小点覆盖数。
又有二分图里:最小点覆盖数 = 最大匹配数。即求二分图的最大匹配即可。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#include <queue>
#include <vector>
#define f(i,a,b) for(i = a;i<=b;i++)
#define fi(i,a,b) for(i = a;i>=b;i--)

using namespace std;

int G[1000][1000];
int p[1000];
int pre[1000];
int v1,v2;

bool dfs(int x){
    int i;
    f(i,1,v2)
        if(G[x][i]&&!p[i]){
            p[i] = 1;
            if(!pre[i]||dfs(pre[i])){
                pre[i] = x;
                return true;
            }
        }
    return false;
}

int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    v1 = v2 = n;
    int i;
    memset(G,0,sizeof(G));
    f(i,1,m){
        int a,b;
        scanf("%d%d",&a,&b);
        G[a][b] = 1;
    }

    int sum = 0;
    memset(pre,0,sizeof(pre));
    f(i,1,v1){
        memset(p,0,sizeof(p));
        if(dfs(i)) sum++;
    }

    printf("%d\n",sum);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值