POJ3020 二分图最大匹配

Antenna Placement
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7873 Accepted: 3908

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them.

Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered?

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set [‘‘,’o’]. A ‘‘-character symbolises a point of interest, whereas a ‘o’-character represents open space.

Output

For each scenario, output the minimum number of antennas necessary to cover all ‘*’-entries in the scenario’s matrix, on a row of its own.
Sample Input

2
7 9
ooo**oooo
*oo*ooo
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17
5

题意:
有几个城市,用“*”表示。每个基站可以覆盖两个点,问在一个图里最少可以建多少个基站就可以覆盖所有的城市。
题解:
由于是在方格上,可以知道,如果对城市染色。那么一定可以只用两种颜色就可以让相邻的的点颜色不同(可以想象国际象棋棋盘得到此结论),那么就可以凭借此构造二分图。又一个基站可以覆盖两个城市。那么可以先求出二分图的最大匹配,每一个匹配边就是一个基站。剩下有一些孤立的城市,再每一个孤立的城市建一个基站。总的基站就是建的最少的。假设最大匹配数是ans,则孤立的点为V0+V1-2*ans。可知最终结果为V0+V1-2*ans+ans = V0+V1-ans。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#include <queue>
#include <vector>
#define f(i,a,b) for(i = a;i<=b;i++)
#define fi(i,a,b) for(i = a;i>=b;i--)

using namespace std;

struct Po
{
    int x,v;
};

int P[1000][1000];
Po G[1000][1000];
int GG[1000][1000];
int vis[5500];
int pre[5500];
int h,w,V[5];
Po Move[] = {-1,0, 1,0, 0,-1, 0,1};

void init(){
    memset(P,0,sizeof(P));
    int i,j,p = 0;
    f(i,0,905){
        if(p) p = 0;
        else p = 1;
        for(j = p;j<=905;j+=2)
            P[i][j] = 1;
    }
}

bool IsTrue(int a,int b){
    if(a>=1&&a<=h&&b>=1&&b<=w&&G[a][b].x)
        return true;
    return false;
}

bool DFS(int k){
    int i;
    f(i,1,V[1]){
        if(GG[k][i]&&!vis[i]){
            vis[i] = 1;
            if(!pre[i]||DFS(pre[i])){
                pre[i] = k;
                return true;
            }
        }
    }
    return false;
}

int main()
{
//  freopen("data.in","r",stdin);
    init();
    int N;
    scanf("%d\n",&N);
    while(N--) {
        V[0] = V[1] = 0;
        memset(G,0,sizeof(G));
        memset(V,0,sizeof(V));
        scanf("%d%d\n",&h,&w);
        int i,j;
        f(i,1,h){
            f(j,1,w){
                char c = getchar();
                if(c == '*'){
                    G[i][j].x = ++V[P[i][j]];
                    G[i][j].v = P[i][j];
                }
            }
            getchar();
        }

        memset(GG,0,sizeof(GG));
        f(i,1,h)
            f(j,1,w){
                if(G[i][j].x&&P[i][j] == 0){
                    int k;
                    f(k,0,3){
                        int a = i+Move[k].v;
                        int b = j+Move[k].x;
                        if(IsTrue(a,b))
                            GG[G[i][j].x][G[a][b].x] = 1;
                    }
                }
            }
        int ans = 0;
        memset(pre,0,sizeof(pre));
        f(i,1,V[0]){
            memset(vis,0,sizeof(vis));
            if(DFS(i))
                ans++;
        }
        printf("%d\n",V[0]+V[1]-ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值