POJ 1703 并查集

题目

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 38704 Accepted: 11915

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

  1. D [a] [b]
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

  2. A [a] [b]
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output

For each message “A [a] [b]” in each case, your program should give the judgment based on the information got before. The answers might be one of “In the same gang.”, “In different gangs.” and “Not sure yet.”
Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

题解

有两个帮派,给出一些信息。D表示俩个罪犯不是一个帮派的,A询问这两个帮派是否是一个帮派的。询问结果给出是或者不是或者不确定。

题解

可以比较巧妙地构建并查集,我们还是想两个帮派各一个集合。但是如何已知的帮派放到一个集合里?(如果不放就不能知道关系是否被确定了)
考虑只有两个帮派,那么是不是一个帮派和对立帮派的对立帮派就是一个帮派的?那么我们用一个Not[i]表示罪犯i不同帮派的人。用一个人就能代替对面帮派整个集合。然后就可以查询了。
PS:买一送一poj2492也是一样的做法。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stack>
#include <string>
#include <set>
#include <cmath>
#include <map>
#include <queue>
#include <sstream>
#include <vector>
#define m0(a) memset(a,0,sizeof(a))
#define mm(a) memset(a,0x3f,sizeof(a))
#define m_1(a) memset(a,-1,sizeof(a))
#define f(i,a,b) for(i = a;i<=b;i++)
#define fi(i,a,b) for(i = a;i>=b;i--)
#define lowbit(a) ((a)&(-a))
#define FFR freopen("data.in","r",stdin)
#define FFW freopen("data.out","w",stdout)
#define SIGN_MAX 0x3f3f3f3f

using namespace std;
#define SIZE 1000000+10

int p[SIZE];
int Not[SIZE];
int h[SIZE];

void init(int n){
    int i;
    f(i,1,n){
        p[i] = i;
        h[i] = 1;
    }
    m0(Not);
}

int Find(int k){
    if(p[k]==k) return k;
    return p[k] = Find(p[k]);
}

void Union(int b,int c){
    int ta = Find(b),tb = Find(c);
    if(h[ta]>h[tb]){
        p[tb] = ta;
        h[ta] += h[tb];
    }else{
        p[ta] = tb;
        h[tb] += h[ta];
    }
}

bool IsTrue(int a,int b){
    return Find(a) == Find(b);
}

int main()
{
    //ios_base::sync_with_stdio(false); cin.tie(0);
    int N;
    scanf("%d",&N);
    while(N--) {
        int n,m;
        scanf("%d%d",&n,&m);
        char a[10];
        int b,c;
        int i,j;

        init(n);

        f(i,1,m){
            scanf("%s%d%d",a,&b,&c);
            if(a[0]=='A'){
                int ta = Find(b),tb = Find(c);
                if(ta==tb)
                    printf("In the same gang.\n");
                else if(IsTrue(b,Not[c])||IsTrue(Not[c],b))
                    printf("In different gangs.\n");
                else
                    printf("Not sure yet.\n");
            }else{
                if(Not[b]==0&&Not[c]==0){
                    Not[b] = c;
                    Not[c] = b;
                }else if(Not[b]==0&&Not[c]!=0){
                    Not[b] = c;
                    Union(Not[c],b);
                }else if(Not[b]!=0&&Not[c]==0){
                    Not[c] = b;
                    Union(Not[b],c);
                }else{
                    Union(Not[c],b);
                    Union(Not[b],c);
                }
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值