1002. A+B for Polynomials(25)C语言实现:多项式A与B的和

多项式A与B的和

这次,假设A和B是两个多项式,求A与B的和多项式。 

输入

每个输入文件包含一个测试实例。每个实例有两行,每行包含一个多项式的信息:

K N1 aN1 N2 aN2 ... NK aNK,其中K为多项式中非0项的个数,Ni 和

 aNi (i=1, 2, ..., K) 分别为指数和系数。数的范围是1 <= K <= 10,0<= NK < ... < N2 < N1 <=1000。

输出

对于每个测试实例,你需要在一行内输出A与B的和,格式与输入时相同。注意每行的结尾不能有多余的空格。小数精确到一位。 

样例输入:

2 1 2.4 0 3.2

2 2 1.5 1 0.5

样例输出:

3 2 1.5 1 2.9 03.2

#include <stdio.h>
#include <stdlib.h>
#define N 25
int main(){        
    int a1[N],b1[N],c1[N];
    double a2[N],b2[N],c2[N];
    int n , m ,nm = 0 ;
    int i = 0 , j = 0 ,k = 0 ;
    int tmpn ;
    double tmpm ;
    int num = 0;
    int exist = 0 ;
    scanf("%d",&n);//输入第1个多项式
    while(i!=n){
        scanf("%d %lf",&a1[i],&a2[i]);
        i++;
    }
    scanf("%d",&m); //输入第2个多项式
    i = 0;
    while(i!=m){
        scanf("%d %lf",&b1[i],&b2[i]);
        i++;
    }
    
    for(i = 0 ; i < n ; i++){
        exist = 0 ;
        for(j = 0 ; j < m ; j++){
            if(a1[i] == b1[j]){ //如果第1、2个多项式指数相等
                exist = 1;
                nm++;
                if((a2[i] + b2[j])==0){
                    b2[j] = 0;
                    break;
                }
                c1[num] = a1[i];
                c2[num]=a2[i]+ b2[j];
                num++;
                b2[j] = 0;
                break;
            }
        }
        if(exist==0){
            c1[num] =a1[i];
            c2[num]=a2[i];
            num++;
        }
    }
    if(nm < m){
        for(j = 0 ; j < m ; j++){
            if(b2[j] != 0){
                c1[num] = b1[j];
                c2[num] = b2[j];
                num++;
            }
        }
    }        
    printf("%d",num);//输出项数
    for(j = 0 ; j < num ; j ++)
    {
        for(k=j;k<num ; k++){
            if(c1[j] < c1[k]){
                tmpn = c1[j];
                c1[j] = c1[k];
                c1[k] = tmpn ;

                tmpm = c2[j];
                c2[j] = c2[k];
                c2[k] = tmpm ;    
            }
        }
        printf(" %d %.1f", c1[j],c2[j]);
    }
    return 0;
}

题目原文如下:

1002. A+B for Polynomials (25)

This time, you are supposed to find A+B where A and B are twopolynomials.

Input

Each input file contains one test case. Each case occupies 2 lines,and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NKaNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2, ..., K) are the exponents and coefficients, respectively. It is given that 1<= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line,with the same format as the input. Notice that there must be NO extra space atthe end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2

2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

追梦2017

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值