Elevator (1008. Elevator (20) | ProgrammingAbility Test https://www.patest.cn/contests/pat-a-practise/1008)
The highest building in our city has onlyone elevator(电梯). A request list is made up with N positive numbers. The numbers denote atwhich floors the elevator will stop, in specified order. It costs 6 seconds tomove the elevator up one floor, and 4 seconds to move down one floor. Theelevator will stay for 5 seconds at each stop.
For a given request list, you are tocompute the total time spent to fulfill the requests on the list. The elevatoris on the 0th floor at the beginning and does not have to return to the groundfloor when the requests are fulfilled.
Input Specification:
Each input file contains one test case.Each case contains a positive integer N, followed by N positive numbers. Allthe numbers in the input are less than 100.
Output Specification:
For each test case, print the total time ona single line.
Sample Input:
3 2 3 1
Sample Output:
41
题目翻译:1008.电梯
在我们的城市里,最高的建筑物里只有一部电梯。有一份由N个正数组成的请求列表。这些数表示电梯将会以规定的顺序在哪些楼层停下。电梯升高一层需要6秒,下降一层需要4秒。每次停下电梯将花费5秒。
给你一个请求列表,你需要计算出完成列表里的请求总共花费的时间。一开始电梯在0层。当请求全部完成时,电梯不需要回到底层。
输入说明:
每个输入文件包含一个测试实例。每个实例包含一个正整数N,后面跟着N个数字。所有输入的数字小于100。
输出说明:
对于每个测试实例,在一行中输出总时间。
样例输入:
3 2 3 1
样例输出:
41
#include<stdio.h>
#define N 100
int main()
{
int n,sum=0,i,t,c[N]={0};
scanf("%d",&n);
for(i=1;i<n+1;i++){
scanf("%d",&c[i]);
}
for(i=0;i<n;i++){
if(c[i+1]>c[i]){
sum+=(c[i+1]-c[i])*6;
}
else sum+=(c[i]-c[i+1])*4;
sum+=5;
}
printf("%d\n",sum);
return 0;
}