hdu 4301 Divide Chocolate (dp )

Problem Description
It is well known that claire likes dessert very much, especially chocolate. But as a girl she also focuses on the intake of calories each day. To satisfy both of the two desires, claire makes a decision that each chocolate should be divided into several parts, and each time she will enjoy only one part of the chocolate. Obviously clever claire can easily accomplish the division, but she is curious about how many ways there are to divide the chocolate.

To simplify this problem, the chocolate can be seen as a rectangular contains n*2 grids (see above). And for a legal division plan, each part contains one or more grids that are connected. We say two grids are connected only if they share an edge with each other or they are both connected with a third grid that belongs to the same part. And please note, because of the amazing craft, each grid is different with others, so symmetrical division methods should be seen as different.
 

Input
First line of the input contains one integer indicates the number of test cases. For each case, there is a single line containing two integers n (1<=n<=1000) and k (1<=k<=2*n).n denotes the size of the chocolate and k denotes the number of parts claire wants to divide it into.
 

Output
For each case please print the answer (the number of different ways to divide the chocolate) module 100000007 in a single line.�
 

Sample Input
  
  
2 2 1 5 2
 

Sample Output
  
  
1 45
 

 code:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<iostream>
using namespace std;
typedef long long LL;

int T;
int n,m;

const int mod=100000007;

int dp[1200][2020][2];

int main()
{
    memset(dp,0,sizeof(dp));
    scanf("%d",&T);

    while(T--)
    {
        scanf("%d%d",&n,&m);

        dp[1][1][0]=1;
        dp[1][2][1]=1;

        for(int i=2;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                dp[i][j][0] = (dp[i-1][j][0] + dp[i-1][j][1]*2 + dp[i-1][j-1][0] + dp[i-1][j-1][1])%mod;

                dp[i][j][1] = (dp[i-1][j][1] + dp[i-1][j-1][0] * 2 + dp[i-1][j-1][1] * 2)%mod;

                if(j>=2) dp[i][j][1]=(dp[i][j][1]+dp[i-1][j-2][1] + dp[i-1][j-2][0])%mod;

            }
        }

        printf("%d\n",(dp[n][m][0]+dp[n][m][1])%mod);

    }

    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值