HDU 4301 Divide Chocolate (状态转移比较多的dp)

题目HDU 4301

简单的dp但是状态转移太多。。。

0表示未分割,1表示分割。

一共12种状态转移。。。。

i=当前竖列,j=分割部分;

第一组:没有增加分割部分;

a,i-1分割,i不分割   有两种

b,i-1分割,i分割 有一种

c,i-1不分割 i 不分割 有一种

第二组:增加一部分;

a,i-1分割,i不分割   有一种

b,i-1分割,i分割 有两种

c,i-1不分割 i 不分割 有一种

d,i-1不分割 i 分割 有两种

第三组:增加两部分;

a,i-1分割,i分割 有一种

b,i-1不分割 i 分割 有一种


共计12种!!!

Divide Chocolate

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
It is well known that claire likes dessert very much, especially chocolate. But as a girl she also focuses on the intake of calories each day. To satisfy both of the two desires, claire makes a decision that each chocolate should be divided into several parts, and each time she will enjoy only one part of the chocolate. Obviously clever claire can easily accomplish the division, but she is curious about how many ways there are to divide the chocolate.

To simplify this problem, the chocolate can be seen as a rectangular contains n*2 grids (see above). And for a legal division plan, each part contains one or more grids that are connected. We say two grids are connected only if they share an edge with each other or they are both connected with a third grid that belongs to the same part. And please note, because of the amazing craft, each grid is different with others, so symmetrical division methods should be seen as different.
 

Input
First line of the input contains one integer indicates the number of test cases. For each case, there is a single line containing two integers n (1<=n<=1000) and k (1<=k<=2*n).n denotes the size of the chocolate and k denotes the number of parts claire wants to divide it into.
 

Output
For each case please print the answer (the number of different ways to divide the chocolate) module 100000007 in a single line.�
 

Sample Input
  
  
2 2 1 5 2
 

Sample Output
  
  
1 45
 

代码如下:

#pragma comment(linker, "/STACK:102400000,102400000")
#include "iostream"
#include "cstring"
#include "algorithm"
#include "cmath"
#include "cstdio"
#include "sstream"
#include "queue"
#include "vector"
#include "string"
#include "stack"
#include "cstdlib"
#include "deque"
#include "fstream"
#include "map"
using namespace std;
typedef long long LL;
const int INF = 0x1fffffff;
const int MAXN = 1000000+100;
#define eps 1e-14
const int mod = 100000007;

LL dp[1000+10][2000+10][2];
int t,n,k;

void dodp()
{
    memset(dp,0,sizeof dp);
    dp[1][1][0]=1;//第一列的状态
    dp[1][2][1]=1;
    for (int i=2;i<1003;i++)
    for (int j=1;j<=i*2;j++)
    {
        dp[i][j][0]=(dp[i-1][j][0]+2*dp[i-1][j][1]+dp[i-1][j-1][1]+dp[i-1][j-1][0])%mod;//当前列不分割
        dp[i][j][1]=(dp[i-1][j][1]+2*(dp[i-1][j-1][0]+dp[i-1][j-1][1])+dp[i-1][j-2][0]+dp[i-1][j-2][1])%mod;//当前列分割
    }
}

int main()
{
    dodp();
    freopen("in","r",stdin);
    cin>>t;
    while(t--)
    {
        cin>>n>>k;
        cout<<(dp[n][k][0]+dp[n][k][1])%mod<<endl;
    }
  return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值