1121 Damn Single Pat_Advanced

 

 

 

1121 Damn Single (25 分)

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:

5
10000 23333 44444 55555 88888

 这道题可以用set的erase函数很形象,去除掉被错误插入进set的那个元素(遍历到一个人有对象,不仅此人不能进入单身名单,而且也要把Ta对象从单身名单擦去)

#include<vector>            // 自己与对象两者
#include<iostream>
#include<set>
using namespace std;
int couple[100010];             // 存储的是对象
bool visited[100010];           // 来了吗
int main() {
    int n, a, b, m, c;
    cin >> n;
    for (int i = 0; i < n; i++) {
        cin >> a >> b;
        couple[a] = b;
        couple[b] = a;
    }
    cin >> m;
    set<int> s;
    for (int i = 0; i < m; i++) {
        cin >> c;
        if (visited[couple[c]] == false) {  // 对象没来时
            s.insert(c);           // 自己进入单身名单
            visited[c] = true;     // 把自己设置为已来
        }
        else
        {
            s.erase(couple[c]);    // 对象已来,把以来的对象从单身名单中去掉
        }
    }
    printf("%d\n", s.size());
    for (auto it = s.begin(); it != s.end(); it++) {
        if (it != s.begin()) cout << " ";
        printf("%05d", *it);
    }
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值