【POJ2013】:Symmetric Order

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 10315 Accepted: 6401
Description
In your job at Albatross Circus Management (yes, it’s run by a bunch of clowns), you have just finished writing a program whose output is a list of names in nondescending order by length (so that each name is at least as long as the one preceding it). However, your boss does not like the way the output looks, and instead wants the output to appear more symmetric, with the shorter strings at the top and bottom and the longer strings in the middle. His rule is that each pair of names belongs on opposite ends of the list, and the first name in the pair is always in the top part of the list. In the first example set below, Bo and Pat are the first pair, Jean and Kevin the second pair, etc.
Input
The input consists of one or more sets of strings, followed by a final line containing only the value 0. Each set starts with a line containing an integer, n, which is the number of strings in the set, followed by n strings, one per line, sorted in nondescending order by length. None of the strings contain spaces. There is at least one and no more than 15 strings per set. Each string is at most 25 characters long.
Output
For each input set print “SET n” on a line, where n starts at 1, followed by the output set as shown in the sample output.
Sample Input
7 Bo Pat Jean Kevin Claude William Marybeth 6 Jim Ben Zoe Joey Frederick Annabelle 5 John Bill Fran Stan Cece 0
Sample Output
SET 1 Bo Jean Claude Marybeth William Kevin Pat SET 2 Jim Zoe Frederick Annabelle Joey Ben SET 3 John Fran Cece Stan Bill

题意 :调换顺序,使第一个名字在序列中仍旧是第一个 ,第二个在新序列中在倒数第一个,第三个在新序列中在正数第二个,第四个在新序列中在倒数第二个……

解题方法

很简单,就是通过奇数和偶数的分别讨论然后求出解
直接看代码即可 = =

代码

/// POJ2013
#include <iostream>
#include <string>
using namespace std;
int main(){
    int n,pos=1,i;
    string a[1000];
    while(cin>>n &&n){
        for(i=1;i<=n;i++){
            cin>>a[i];
        }
        cout<<"SET "<<pos<<endl;
        pos++;
        //对偶数的讨论
        if(n%2==0){
            for(i=1;i<=n;i+=2){
                    cout<<a[i]<<endl;
            }
            for(i=n;i>0;i-=2){
                    cout<<a[i]<<endl;
            }   
        }
        //对奇数的讨论
        else{
            for(i=1;i<=n;i+=2){
                    cout<<a[i]<<endl;
            }
            for(i=n-1;i>0;i-=2){
                    cout<<a[i]<<endl;
            }   
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值