cmake 报错 CMake Error at CMakeLists.txt:30 (cmake_minimum_required): CMake 3.8 or higher is requir

当我使用cmake命令时,报图中的错
在这里插入图片描述
第一步先移除原有的cmake

sudo apt remove cmake

在这里插入图片描述
在这里插入图片描述然后在cmake网站下载安装包
https://cmake.org/download/
我使用的是这个包
在这里插入图片描述解压然后编译安装

cd cmake-3.15.2

在这里插入图片描述

./configure

在这里插入图片描述

make

在这里插入图片描述

sudo make install

在这里插入图片描述

命令:

cmake --version

可查看到camke版本
在这里插入图片描述
但是
在这里插入图片描述

在cmake前加上sudo就可以
在这里插入图片描述

已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 技术黑板 设计师:CSDN官方博客 返回首页