Boring count
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 740 Accepted Submission(s): 302
Problem Description
You are given a string S consisting of lowercase letters, and your task is counting the number of substring that the number of each lowercase letter in the substring is no more than K.
Input
In the first line there is an integer T , indicates the number of test cases.
For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.
[Technical Specification]
1<=T<= 100
1 <= the length of S <= 100000
1 <= K <= 100000
For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.
[Technical Specification]
1<=T<= 100
1 <= the length of S <= 100000
1 <= K <= 100000
Output
For each case, output a line contains the answer.
Sample Input
3 abc 1 abcabc 1 abcabc 2
Sample Output
6 15 21
Source
题目大意:求取有多少个子串中出现次数最多的字母不超过k个的子串数目
题目分析:可以定义两个指针,一个cur , 一个start,可以通过这两个指针,维护他们的位置,每个以cur结尾的子串符合条件的数目就是其中最长的符合条件的子串的长度
题目分析:可以定义两个指针,一个cur , 一个start,可以通过这两个指针,维护他们的位置,每个以cur结尾的子串符合条件的数目就是其中最长的符合条件的子串的长度
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#define MAX 100007
using namespace std;
typedef long long LL;
char s[MAX];
int t,k;
int cnt[27];
bool check ( )
{
for ( int i = 0 ; i < 26 ; i++ )
if ( cnt[i] > k )
return false;
return true;
}
LL ans;
int main ( )
{
scanf ( "%d" , &t );
while ( t-- )
{
scanf ( "%s" , s );
scanf ( "%d" , &k );
int start = 0 , cur;
memset ( cnt , 0 , sizeof ( cnt ) );
int len = strlen(s);
ans = 0;
for ( cur = 0; cur < len ; cur++ )
{
cnt[s[cur]-'a']++;
while ( start <= cur && !check() )
cnt[s[start++]-'a']--;
ans += cur-start+1;
}
printf ( "%lld\n" , ans );
}
}