hdu 1133 Buy the Ticket(卡特兰数变形+组合数学+java大数)

Buy the Ticket

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5021    Accepted Submission(s): 2095


Problem Description
The "Harry Potter and the Goblet of Fire" will be on show in the next few days. As a crazy fan of Harry Potter, you will go to the cinema and have the first sight, won’t you?

Suppose the cinema only has one ticket-office and the price for per-ticket is 50 dollars. The queue for buying the tickets is consisted of m + n persons (m persons each only has the 50-dollar bill and n persons each only has the 100-dollar bill).

Now the problem for you is to calculate the number of different ways of the queue that the buying process won't be stopped from the first person till the last person.
Note: initially the ticket-office has no money.

The buying process will be stopped on the occasion that the ticket-office has no 50-dollar bill but the first person of the queue only has the 100-dollar bill.
 

Input
The input file contains several test cases. Each test case is made up of two integer numbers: m and n. It is terminated by m = n = 0. Otherwise, m, n <=100.
 

Output
For each test case, first print the test number (counting from 1) in one line, then output the number of different ways in another line.
 

Sample Input
  
  
3 0 3 1 3 3 0 0
 

Sample Output
  
  
Test #1: 6 Test #2: 18 Test #3: 180
 题目分析:这道题是对卡特兰数的变形,然后还利用了高精度,首先我们假装推下推下公式:
首先可以将有50的看做1,有100的看做0,那么就相当于在m+n个位置中选m个位置放1,这是所有的情况,那么我们还得剔除不行的情况,也就是在2*t+1个位置上出现了t+1个0,而这种情况下,后面就剩下m-t个1,n-t-1个0,那么我们把0和1互换,就变成在m+n个数中选取m+1个0,一定会对应一个不行的情况,因为每个人是特异的没所以还要乘上m!和n!,那么问题解决了吗?并没有,因为还有n==0和n>m的情况要特判...
package hdu;

import java.util.Scanner;
import java.math.BigInteger;

public class Main 
{
	static final int MAX = 107;
	static BigInteger [][] c = new BigInteger[MAX*2][MAX*2];
	static BigInteger []f = new BigInteger[MAX];
	
	static void init ( )
	{
		c[0][0] = c[1][1] = c[1][0] = BigInteger.ONE;
		for ( int i = 2 ; i < MAX*2 ; i++ )
			for ( int j = 0 ; j <= i ; j++ )
				if ( j ==0 || j == i ) c[i][j] = BigInteger.ONE;
				else c[i][j] = c[i-1][j] .add(c[i-1][j-1]);
		f[0] = f[1] = BigInteger.ONE;
		for ( int i = 2 ; i <  MAX ; i++ )
			f[i] = f[i-1].multiply(BigInteger.valueOf(i) );			
	}
	
	public static void main ( String args[] )
	{
		Scanner cin = new Scanner ( System.in );
		int m,n;
		int cc= 1;
	     init();
		while ( cin.hasNext() )
		{
			m = cin.nextInt();
			n = cin.nextInt();
			if ( m == 0 && n == 0 ) break;
			System.out.println ( "Test #" + cc++ + ":" );
			if ( m < n ) 
			{
				System.out.println ( "0" );
				continue;
			}
			if ( n == 0 )
			{
				System.out.println ( f[m] );
				continue;
			}
			System.out.println ( f[m].multiply(f[n]).multiply( c[m+n][m].subtract( c[m+n][m+1]) ) );
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值