hdu 1131 Count the Trees (卡特兰数+java大数)

Count the Trees

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1640    Accepted Submission(s): 1095


Problem Description
Another common social inability is known as ACM (Abnormally Compulsive Meditation). This psychological disorder is somewhat common among programmers. It can be described as the temporary (although frequent) loss of the faculty of speech when the whole power of the brain is applied to something extremely interesting or challenging.
Juan is a very gifted programmer, and has a severe case of ACM (he even participated in an ACM world championship a few months ago). Lately, his loved ones are worried about him, because he has found a new exciting problem to exercise his intellectual powers, and he has been speechless for several weeks now. The problem is the determination of the number of different labeled binary trees that can be built using exactly n different elements.

For example, given one element A, just one binary tree can be formed (using A as the root of the tree). With two elements, A and B, four different binary trees can be created, as shown in the figure.

If you are able to provide a solution for this problem, Juan will be able to talk again, and his friends and family will be forever grateful.

 

Input
The input will consist of several input cases, one per line. Each input case will be specified by the number n ( 1 ≤ n ≤ 100 ) of different elements that must be used to form the trees. A number 0 will mark the end of input and is not to be processed.
 

Output
For each input case print the number of binary trees that can be built using the n elements, followed by a newline character.
 

Sample Input
  
  
1 2 10 25 0
 

Sample Output
  
  
1 4 60949324800 75414671852339208296275849248768000000
 题目分析:利用n个节点,就是选出一个节点,然后剩下的选择左子树或者右子树,h(n) = h(i)*h(n-1-i).....
符合卡特兰数的递归计算方法,所以直接代入公式即可
package hdu;

import java.util.Scanner;
import java.math.BigInteger;

public class Main 
{
	static final int MAX = 107;
	static BigInteger [][]c = new BigInteger [MAX*2][MAX*2];
	static BigInteger []f = new BigInteger[MAX];
	
	static void init ( )
	{
		c[1][1] = c[0][0] = c[1][0] = BigInteger.ONE;
		for ( int i = 2 ; i < MAX*2 ; i++ )
			for ( int j = 0 ; j <= i ; j++ )
				if ( j == 0 || j == i ) c[i][j] = BigInteger.ONE;
				else c[i][j] = c[i-1][j].add(c[i-1][j-1]);
		f[0] = f[1] = BigInteger.ONE;
		for ( int i = 2 ; i < MAX ; i++ )
			f[i] = f[i-1].multiply(BigInteger.valueOf(i));
	}
	
	public static void main ( String args[] )
	{
		Scanner cin = new Scanner ( System.in );
		int n;
		init ();
		while ( cin.hasNext() )
		{
			n = cin.nextInt();
			if ( n ==  0 ) break;
			System.out.println ( c[2*n][n].divide(BigInteger.valueOf(n+1)).multiply(f[n]) );
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值