hdu 5210 Greatest Greatest Common Divisor

Greatest Greatest Common Divisor

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1014    Accepted Submission(s): 435


Problem Description
Pick two numbers ai,aj(ij) from a sequence to maximize the value of their greatest common divisor.
 

Input
Multiple test cases. In the first line there is an integer T , indicating the number of test cases. For each test cases, the first line contains an integer n , the size of the sequence. Next line contains n numbers, from a1 to an . 1T100,2n105,1ai105 . The case for n104 is no more than 10 .
Output
For each test case, output one line. The output format is Case # x : ans , x is the case number, starting from 1 , ans is the maximum value of greatest common divisor.
 

Sample Input
  
  
2 4 1 2 3 4 3 3 6 9
 

Sample Output
  
  
Case #1: 2 Case #2: 3
题目大意:简单
题目分析:
先将10^5以内的所有数的因数筛出来,统计每个因数出现的次数,然后倒序遍历,知道cnt[i]>1时,得到最大的最大公约数
 
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#define MAX 100007

using namespace std;

typedef long long LL;

int t,n;
int a[MAX];
int cnt[MAX];

int main ( )
{
    scanf ( "%d" , &t );
    int cc = 1;
    while ( t-- )
    {
        scanf ( "%d" , &n );
        for ( int i = 0 ; i < n ; i++ )
            scanf ( "%d" , &a[i] );

        memset ( cnt  ,  0 , sizeof ( cnt ) );

        for ( int i = 0 ; i < n ; i++ )
            for ( int j = 1 ; j*j <= a[i] ; j++ )
                if ( a[i]%j == 0 ) 
                {
                    cnt[j]++;
                    if ( j != a[i]/j ) cnt[a[i]/j]++;
                }
        for ( int i = MAX-1 ; i >= 1 ; i-- )
            if ( cnt[i] >= 2 )
            {
                printf ( "Case #%d: %d\n" , cc++ , i );
                break;
            }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值