hdu5207Greatest Greatest Common Divisor+枚举

Description
Pick two numbers from a sequence to maximize the value of their greatest common divisor.

Input
Multiple test cases. In the first line there is an integer , indicating the number of test cases. For each test cases, the first line contains an integer , the size of the sequence. Next line contains numbers, from to . . The case for is no more than .

Output
For each test case, output one line. The output format is Case # : , is the case number, starting from , is the maximum value of greatest common divisor.

Sample Input

2
4
1 2 3 4
3
3 6 9

Sample Output

Case #1: 2
Case #2: 3
给一堆数,找出任意两个数之间的最大的公约数。
枚举每一个数的约数,记录个数。这样总的约数个数>=2就是某两个数的约数情况,直接从最大的饭后遍历,找到第一个>2的即可。

#include<bits/stdc++.h>
using namespace std;

int ans[100005];
int main(){
    int t;
    scanf("%d",&t);
    for(int cas=1;cas<=t;cas++){
        int n;
        scanf("%d",&n);
        memset(ans,0,sizeof(ans));
        for(int i=1;i<=n;i++){
            int x;
            scanf("%d",&x);
            for(int j=1;j*j<=x;j++){
                if(x%j==0){
                    ans[j]++;
                    if(x/j!=j) ans[x/j]++;
                }
            }
        }
        for(int i=100005;i>=1;i--){
            if(ans[i]>=2){
                printf("Case #%d: %d\n",cas,i);
                break;
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值