PAT甲级1020(附带前中序遍历の绝对干货)

引子

我之前对遍历推导这块没怎么动脑子,凭感觉。所以这题是先参考了百度经验,别笑,这个链接,我觉得讲得非常清楚。
https://jingyan.baidu.com/article/cdddd41cb8d79753ca00e144.html
读懂它的前提是,你静下心来,而不是像找规律一样,似是而非地懂了。那样毫无卵用。

通过推导它再举一反三推导其他题,你发现,思路是:

先通过后序的特点,找总的根节点。然后确定总根的右节点,一般是postorder最后一个节点(总根)的前一个节点post[4]=5。然后通过结合后序中序中相同的数字,如65,56确定好它们在一个最小子树中的位置,逐渐完善总根的右子树。然后找总根的左节点。一般是postorder中从后往前把右子树的节点数光的第一个节点。

则从PostOrder看,左子树的根节点序号为root的序号(比如0~5的5)-右子树节点的个数(2)-1=2。左子树根节点为post[2]=2~

int post[] = {3, 4, 2, 6, 5, 1};
int in[] = {3, 2, 4, 1, 6, 5};
很多文章说是root-(end-i+1)。但我比较能理解我自己的式子。当然它式子的end-i,这里的end是InOrder最后一位的序号,i是InOrder的根节点,相减是右子树节点数没错。


下面是根据上述数组推导前序的代码:

#include<cstdio>
using namespace std;
int post[] = {3, 4, 2, 6, 5, 1};
int in[] = {3, 2, 4, 1, 6, 5};
void pre(int root,int start,int end){
    if(start>end) return;
    int i=start;//找到根节点在InOrder中序号
    while(i<end&&in[i]!=post[root]) i++;
     printf("%d",post[root]);//打印根节点
     pre(root-(end-i)-1,start,i-1);//左根节点从postorder角度看,i-1从inorder角度看
     pre(root-1,i+1,end);//右根节点从postorder角度看,i+1从inorder角度看
}
int main(){
    pre(5,0,5);
    return 0;
}

正文

1020 Tree Traversals (25)(25 分)
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:

4 1 6 3 5 7 2


这题没啥头绪,先学习柳婼大神的
https://www.liuchuo.net/archives/2100

#include<iostream>
#include<vector>
using namespace std;
vector<int> post,in,level(100000,-1);
void pre(int root,int start,int end,int index){
    if(start>end) return;
    int i=start;//找到根节点在InOrder中序号
    while(i<end&&in[i]!=post[root])i++;
    // printf("%d",post[root]);//打印根节点
     level[index]=post[root];
     pre(root-(end-i)-1,start,i-1,2*index+1);//左根节点从postorder角度看,i-1从inorder角度看
     pre(root-1,i+1,end,2*index+2);//右根节点从postorder角度看,i+1从inorder角度看
}

int main(){
  int n,cnt=0;
  cin>>n;
  post.resize(n);
  in.resize(n);
  for(int i=0;i<n;i++){
    scanf("%d",&post[i]);

  }

  for(int i=0;i<n;i++){
    scanf("%d",&in[i]);

  }
  pre(n-1,0,n-1,0);
  for(int i=0;i<level.size();i++){
    if(level[i]!=-1){
      if(cnt!=0) cout<<" ";
      cout<<level[i];
      cnt++;
    }
    if(cnt==n)break;
  }
  return 0;
}

//有机会带来自己的理解。

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值