PAT甲级1058(进制转换的“/” ,“%”干货!)

题目

1058 A+B in Hogwarts(20 分)
If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,10^7], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:
Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28


题解

#include<iostream>
int main()
{
    long a[3]={},b[3]={},c[3]={};
    scanf("%ld.%ld.%ld %ld.%ld.%ld",&a[0],&b[0],&c[0],&a[1],&b[1],&c[1]);
    if(c[0]+c[1]>=29)
    {
        c[2]=(c[0]+c[1])%29;
        b[2]++;
    }else{
        c[2]=c[0]+c[1];
    }
    if(b[0]+b[1]+b[2]>=17)
    {
        b[2]+=(b[0]+b[1])-17;
        a[2]++;
    }else{
        b[2]+=b[0]+b[1];
    }
    a[2]+=a[0]+a[1];
    printf("%ld.%ld.%ld\n",a[2],b[2],c[2]);
    return 0;
}

这算是一种最朴素的解法了。记得数组要初始化。还有,防止大数溢出用long,甚至long long。


#include <iostream>
using namespace std;
int main() {
    long long a, b, c, d, e, f;
    scanf("%lld.%lld.%lld %lld.%lld.%lld", &a, &b, &c, &d, &e, &f);
    long long num = c + b * 29 + a * 29 * 17 + f + e * 29 + d * 29 * 17;
    long long g = num / (17 * 29);
    num = num % (17 * 29);
    printf("%lld.%lld.%lld", g, num / 29, num % 29);
    return 0;
}

柳神偏爱将总的数值算出来,然后用/两个进制的乘积算出从右往左第三位的值,(同理/一个进制值=从右往左第二位的值),用%(两个进制值相乘)算出后两位的数值,再得最后一位的值。

总结就是“/”1位进制值得倒数第二位,“%”1位进制值得倒数一位

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值